DTPO Web Server - Problem Accessing the Database

I have DTPO 2.7.5 set up on a Mac Mini running 10.6.8 (Snow Leopard). Until the recent release, I was able to access the web server with my iPad and iPhone, both running iOS 7.1.1 until I upgraded DTPO. Now I can see the database name, but when I click on it, I get:

“Problem accessing the database.”

Is anyone else seeing this? I’ve made no firewall or other changes. It simply stopped working.



Same for me, using Mavericks 10.9.2 and iPad on IOS 7.1.1.
Opening Safari in iPad addressing the server and after giving login credentials page-loading just hangs.

Hmm… I’m not seeing this on 7.1.1. Have you rebooted the mobile device recently?

I just rebooted my iPhone (4s) and my iPad 2. Same result.


Since this “appears” to have happened after the last update, is there a way I can get the Current-1 of DTPO and reinstall?


Have you rebooted your Mac?

I have cold-started the Mac, run YASU to clean things up, rebooted the iThings, rebuilt the database.

This is happening on 4 different iThings and started after the last upgrade was pushed. I’d like to go back to the previous version to see if that is the problem.


As far as I know the web sharing in the latest release hasn’t changed in this update.

There is however an issue with the iOS version of Safari and password protected databases, where Safari fails to load parts of the web sharing application after authentication.

Until Apple fixes this issue, there are two options:

  1. Try the following workaround, in the majority of cases it will resolve the issue:
  • Stop the DEVONthink web server
  • Remove the user name and password setting, or if this is set at a database level close any shared databases with password protection.
  • Start the DEVONthink web server without any password set.
  • Connect to the server with your iPad/iPhone
  • Stop the DEVONthink web server
  • Add your password, and/or open password protected shared databases
  • Start the DEVONthink web server.
  1. To use a web browsers such as Dolphin that does not have this issue.

I’ll go with the alternate browser for now. Crazy thing is, the last copy of the user guide claims it was fixed.

Thank you.