DTPro 1.0 to DTPro 1.1, now can't open databases?

I’m running into a major problem with DTPro 1.1; I assume it’s something I’m doing wrong, 'cause nobody else seems to have run into it, but I can’t figure out how to resolve it.

I used to use DT Personal; I upgraded to Pro 1.0 as soon as it came out. I continued to use the same database files as before – in my “~/Library/Application Support/DEVONthink databases” folder, I have a folder called “DEVONthink general” that contains the DEVONthink-1.database through DEVONthink-10.database files. (I also have a couple of other folders, each representing a different DT database, each containing its own set of DEVONthink-1.database through DEVONthink-10.database files.)

In DTPro 1.0, I can choose File > Open, and then I select the “DEVONthink general” folder and click Open, and everything works as expected. (The Open Recent command never worked, but I never bothered to figure out why not.)

But I just upgraded to DTPro 1.1, and now when I choose File > Open and select the “DEVONthink general” folder, the Open button is grayed out.

So it looks like DTPro 1.1 won’t let me use those old-format database files. But I also can’t import them, and I can’t find a way to convert them to the new format, and I can’t restore from backup… I can’t find a way to get 1.1 to recognize them at all.

It looks like I was supposed to somehow convert the Personal databases to Pro ones before upgrading to Pro 1.0, but I can’t find any information about that.

I still have 1.0, and I can still open the old database using that. Is there something I can do to convert them to Pro format?



Just add a .dtBase extension to the database folder and then the File > Open command should work.

Excellent – that worked perfectly. Thanks very much for the fast response!