DTPRO won't open databases

I just got a MacBook Pro and transferred all files from a backup of my previous laptop.

On opening DTPro–which goes fine and very fast–I attempt to open one of my databases. The dialogue briefly appears indicating the database is open, then nothing. There is no database window that shows up. At first I thought with Spaces turned on and a number of apps open, perhaps I was just not “finding” the database window. So I have closed all apps but DTPro. Still no visible database window.

I repaired permissions, even downloaded DTPro anew and removed the prefs file to let DT make a new one. Still no database window.

HOWEVER: I clicked on the application menus and noticed that, for example, the “Tools” menu had all options available! I clicked on “Rebuild Database” and to my surprise, the database I thought wasn’t open proceeded to export and reimport! The window popped open. I thought hurrah!

BUT: then I closed the newly re-created database and attempted to re-open it: no database window, though I can, once again, proceed to rebuild it and get yet another database window!! I check in the new window of the database and all files seem to be there.

I am utterly at a loss: can anyone help?


An additional note:

I can select “New Window” and the database appears!

But no window is visible on the initial database opening.

Sorry to have a one-voice list topic, but:

Toying with Preferences, I found that I had checked “Do Nothing” on startup.

I checked the “Open new window” choice and now all my databases seem to open up and appear right away.

I have always had the “do nothing” checked and never noticed this “window not visible” behavior before.