DTTG 1.1.1 problems

Loaded DTTG 1.1.1, expecting mainly to welcome the handling of .xlsx and .docx. I have a very small .xlsx on the iPad that was sent from GoodReader to DTTG. DTTG still reports it doesn’t know the file type and won’t display it or “Open In”. On sync, DTTG choked on the .xlsx and hung up DTPO on the desktop. No console messages. Reboot everything and hard boot the iPad makes no difference; still hangs.

Personally, though I’d enjoy a robust DTTG, I’m enjoying the continual improvements in GoodReader sync and find that it serves all my syncing needs.

I’ve not tried sending a .xlsx document from GoodReader to DEVONthink To Go, but I find the handeling of .xlsx documents that are synced from DEVONthink to DEVONthink To Go to work fine. Here is a document that I synced this morning, view in portrait mode in DEVONthink To Go.

And what it looks like when sent using the ‘Open In’ from DEVONthink To Go to Numbers iPad.


Seems like the baseline experience with DTTG is YMMV.

Always has been that way, more so than with any other app that I have worked with. It has worked pretty much as expected for me ever since it left alpha status, but for others-not so much.

I just saved the same document to Dropbox, opened it with both Documents To Go and GoodReader on the iPad. Send the document from both apps to DEVONthink To Go and synced them successfully with DEVONthink Pro Office. I’m wondering if you should try your workflow with another .xlsx document-perhaps there is something about the document that is causing the problem?

Synced an .xlsx from the desktop to the iPad with success - I can view it and Open In works.

I suspect the .xlsx that failed did so because it has some merged cells – I don’t really know, though. I might be making that up. :confused: Using DTTG is a craps game - as are a lot of high-profile iPad apps, frankly. I appreciate the developers’ plight - iOS must be a really intractable environment for development. I’m glad I decided not to code for it.

Was the .xslx already in DTTG when you updated to 1.1.1 or did you add it to DTTG after 1.1.1?

Unfortunately, the improvements for .xslx and .docx will only apply to new documents, not existing documents, as there wasn’t a good way to for me to apply the improvements to existing documents. I’m sorry I didn’t state this in the version notes.

Jon, are you recommending that users Reset Synchronization Settings upon updating to 1.1.1? If that, or some other recommendation that was not in the release notes, could you post a sticky item to the DTTG forum with “updated” notes and/or upgrade instructions when such a release is public? This might avoid a few of the “I updated to the newest whizbang DTTG and &$#*€£!!!” complaints.

(Like mine :wink: )

You don’t need to Reset Synchronization Settings. But you will need to perform a “clean” sync of documents. I guess the easiest way to do this is to delete a database from DTTG and sync it again. If that doesn’t work, you’ll have to go to Settings.app and Reset DTTG from there. I hope to fix this in the next update, but if your device supports multitasking, you’ll have to completely quit DTTG before the Reset takes effect.

And yes, I will add that to my build notes to add a sticky for situations like this (and I’ll plan to add one today for that issue).