DTTG 1.5.1 still crashing with RTF files

The latest version of DTTG still crashes repeatedly on any attempt to view a RTF file. Basically still unusable for anyone with a lot of RTF files in their database

Clipped something in to DTTG from a website - now in RTF format. Everything else works as it should (DTTG iPad Air iOS 8.1), but trying to open that single RTF, crashes DTTG back to the home screen.

Everything updated - so presumably on latest version as well.

I’ve just tried to reproduce the issue. How exactly do you clip the RTF from a web page? When using the Clip to DEVONthink action extension I consistently get a bookmark (which is what is expected).

Are all RTFs crashing or just a few? If yes, could you email me one of those crashing RTFs?

It’s just a few - but I had it wrong, it wasn’t clipped in - it was created inside DTTG. I copied text over in Goodreader - off an OCR’ed PDF file. Went back in to DTTG, tapped on the + sign, chose Rich Text, and pasted the text in. It was a short sentence or two of plain text - copied in no problem.

When I click back to the main window, all the files are listed. The PDFs imported from DTPO all work as expected, but the moment I tap into those RTFs - it crashes.

As mentioned - the first RTF made like that, in August, crashes. The new one, made today, also crashes.

A third one - using a different PDF in GoodReader as the source, does the same.

RTF files are still crashing for me. The last update was 10/31, so I appear to have the newest version. Nothing special about the RTF files. None of them work. I deleted and re-synchronized the database. That didn’t help.

Can confirm that RTF files which were finally fixed to open in 1.5.0 now cause a crash in 1.5.1. :frowning: This is actually worse than before when DTG simply could not read the rtf files. I note that these are not clipped rtf files in my case, but just rtf files created in DT Pro on my computer and synchronised into DTG. Can we go back to 1.5.0 until you fix this Eric? Some of us depend professionally on the capacity to read the RTF files on our iPads. I have now turned auto update of my apps off so that at least I have a chance to get warning of future bugs in DTG before allowing it to update.

Any RTF file fails for me, and has for a while now. I just created an RTF file in DT, wrote a line of text “This is a test.” in it, and synced. It didn’t work. In my case, it crashes the app.

Yes, the same for me creating the RTF file in DTTG - I add one word ‘test’ to the file, move the focus away by selecting a different (non-RTF) file, move back and select the test RTF file and DTTG crashes. 1.5.1 with iOS 8.1 on iPad Air 2.

I am also experiencing this problem. I’m running v1.5.1 on OS 8.1, and ALL Rich Text notes crash the app when trying to open them.

This is essentially causes DTTG to be unusable for me, as most of my notes are RTFs. I was just on the phone with my insurance company, who asked for my policy number. “Sure, I have it right here”. --opens DTTG–, --app repeatedly crashes–. “Sorry, I’ll have to call back when I get home to my computer”.

Happens on both my iPad Air and iPhone 6.


On my iPhone 4s i have no crashing on RTF-files.
On my iPad Air all RTF-files are crashing the app.

I did a fresh install of iOS 8.1 on my iPhone. On my iPad just an update from iOS 7. Maybe it has something to do with this?

best regards, Robert

Thank you all for your detailed descriptions of the RTF issue. We have figured out what’s causing it: it only happens on newer devices with a 64-bit processor. It neither happens on any 32-bit device nor in Xcode’s simulator (regardless if you use a simulated 32- or 64-bit device).

It seems that something inside of the Omni RTF editor we’re using is not 64-bit compatible and immediately starts to consume as much memory as it can get. This will be tough to locate but we’re trying to find what’s causing it and provide a fix.

We have also some other options still in the back of our hands. I’ll keep you updated.

Just a quick note that we have fixed this issue for the next release which we will submit to Apple as soon as possible.

So Eric, have you actually submitted the fix to DTTG 1.5.1? As I stressed before I depend on the capacity to read rtf in DTTG on my iPad. It was a relief when you fixed it, but a bitter disappointment when the next upgrade ruined it again! I have been waiting patiently until the promised new fix arrives… but has it actually been submitted? After that, I understand it is in the hands of Apple and their slow review process.

DEVONthink To Go 1.5.2 is online!

“[i]What’s new in 1.5.2:
This maintenance release fixes the crashing RTF editor on 64-bit devices and corrects the screen size of RTF document. It also adds the missing TextExpander update button and fixes a number of issues on iOS 6. Finally, it removes the “Clipped!” voice of the Clip to DEVONthink action extension.

HockeyKit crash reporter framework updated.

RTF editor crashed on 64-bit devices.
RTF editor screen size was wrong and the color picker unusable.
TextExpander Touch support missed button for updating the snippets.
Crash on startup (iOS 6).
Search scope bar was not visible (iOS 6).
Sort button was hardly readable (iOS 6).
Sort options text was missing and switches misplaced (iOS 6).
Audio recorder and camera picker didn’t show on iPad.
“Clipped!” voice of Clip to DEVONthink action extension removed.[/i]"

One RTF bug remains: documents with underlined text crash the editor. Already fixed and version 1.5.3 submitted to Apple for review. It should become available within a week’s time.

Has the problem with garbled Japanese text been solved as well? See support ticket #225272 for details.

As in v1 we continue to use the Omni RTF engine (v2 here in the labs already uses a completely new and may more compatible and capable RTF editor) I guess we won’t solve the problem with garbled Japanese text as least as long as they’re displayed in the editor.

Do they show up correctly when you deselect “Open RTF in edit mode” in DEVONthink To Go’s settings?

No luck when I change the setting. The text is garbled :frowning:
Looking forward to V2, though! It will be nice to be able to read my RTF files :slight_smile:

Fortunately, I primarily work with plain text so it hasn’t been a huge issue for me. But, I imagine it will be with your other Japanese / Chinese / Korean users.