DTTG 3.0.6 crashes after saving webarchive via x-devonthink

I’m using Fiery Feeds as RSS reader and DTTG as a read-later app. If I share an article via x-devonthink with


DTTG opens and crashes shortly after. No webarchive is created but a bookmark.

According to the URL commands this syntax seems correct.

Additionally are there any plans to add commands for clutterfree webarchive or even clutterfree pdf =)

Do you urlencode the title before setting it in the app link?

Hi chrillek,

thanks for your reply. I could check the encoding but I set the title to the String “title” to check if this the problem, but it did not work either.

I could recreate this issue on my iPad and iPhone. Both iOS 14 both 3.0.6 DTTG. And I could record my screen.

This says the logfile:

Exception Subtype: KERN_INVALID_ADDRESS at 0x0000000e17204890
Thread 5 name:  Dispatch queue: com.devonthinktogo.serial.queue
Thread 5 Crashed:

I can provide the ips-logfile and the screenrecord from my iPhone if it is needed.

Do you see any issue with a shortcut this simple?

I tried this shortcut with Fiery and Fiery did not share a Safari Website but an URL. Is there a significant difference?
But this shortcut did not work with Fiery and DTTG. Nothing happens.

Try it with Safari.


On my first try DTTG reacts similar and opens only to crash and send a bookmark to the inbox. The next attempts did not lead to any reaction. No DTTG show up nor did shortcut react in any way.

Got same bug type und same exception type. serial.queue crashed.

Update after reboot:

First attempt with safari works fine. After that every try leads to no reaction as described before.

I added some popups and only the first one was triggered. The second one never appears. This could be the reason because there is no reaction. The shortcuts is not terminated.

Thanks for the info.

Do you need any further information?

In the meantime I found another bug with webarchives:

If a website could not be imported correctly as a clutterfree webarchive

and I tried to get the normal webarchive instead by clicking on the link

and import the webarchive from the article via webclipper

DTTG crashes with bug_type 109 and the same error described earlier. Again com.devonthinktogo.serial.queue crashed.