DTTG always hangs at the same point in sync

For several days, I’ve gotten the same message when syncing: “The connection with the computer timed out. Please check your network connection and try again.” This always happens at the same point in the sync, namely when it’s trying to sync a Group called “Home Dept Indices.” I tried renaming the group, since that was the only way I could think of to even interact with it, but of course it didn’t make any difference. I tried creating an ad hoc network, but my iPad couldn’t see it. I’ve quit and restarted both DTTG and DTPO. This folder only contains 4 text files, all of them created in DTTG itself. The largest is 5.1KB.

Needless to say, I only get this message on the occasions when DTTG doesn’t either refuse to see my computer or just crash, losing data. Which speaking of, when I’m editing text on DTTG, why isn’t it just saved constantly, or at least every thirty seconds? A revision history timeline like the one in SimpleNote would be great.

This is on DTTG 1.1 and DTPO 2.3. When is DTTG going to be updated? It’s been half a year!

Have you checked for an update in iTunes or on your device? DTTG was updated to 1.1.2 in late July, and each release of DTTG has improved syncing.

Actually, I have 1.1.2. I was getting the version number from the question mark icon in the app itself, but the Settings page confirms that I have 1.1.2. This makes sense, since I only got the app in the last couple of weeks.

Similar problem. On the Mac I have a connection time out. On the phone my computer disappears from the list of computers on the network. No syncing at all.

Just to clarify, depending what other files I’ve edited and which databases I select to sync, I can get other files to sync. But when it comes to this group, it always hangs and eventually gives up.

Sorry I’m just getting to this thread now, but there is an issue when syncing groups created in DTTG that causes the sync process to stall. This has been fixed in the upcoming release of DTTG.

If you don’t have many files in that group already, you can delete the group from DTTG, add it to DEVONthink, then sync. That should work until the update is available.

Any idea when the new update is coming? Since I already had a lot of files all in their own folders (the folder structure is critical, since it’s mirroring the structure of an archive), I decided to wait till the new one comes out. But I’m getting a little anxious about not being able to sync.

The update seems to have come out at the end of last week, so it should be available now.

The update did fix that problem, but now it’s returned in a different form. I have one particular problem file (a PDF which I’ve edited in GoodReader), which always crashes the app. Other files in the same database seem to sync, and the other database plus the Global Inbox sync fine, but this file always crashes the sync. Not only that, but because it was created on the computer and not on the iPad, I can’t delete it. Am I doomed?

One other minor point: even after the app has crashed, DTPO thinks that it’s still syncing. When I force-quit the app, it stops syncing, so they’re clearly still in communication.

By the way, I haven’t mentioned this before because it’s minor compared to non-functioning sync, but many folders that I have synced before are now duplicated in DT. I’m not sure, but they might all be empty folders.

I also have some files that have been duplicated, which I think might all have been modified in GoodReader.

1.2.2 doesn’t fix the problem.

Would you be able to send the PDF to us for testing?

Alternatively, you can try using a Debug version of the Sync Agent plugin to see if that can help me pinpoint the area where it’s crashing.

Here are the steps to do that:

  1. Download the Sync Agent attached to this post
  2. Quit DEVONthink Pro
  3. Unzip the Sync Agent and move it to ~/Library/Application Support/DEVONthink Pro 2/Plugins
  4. Start DEVONthink Pro
  5. Open Console.app (in Applications/Utilities) to watch for log messages (you can narrow these down by filtering for “devon”)

Try syncing again. If it fails or stalls, please copy the log messages from Console.app (select the rows and copy them) or take a screenshot.

Those should give me a better idea of what might be happening.

By the way, if you’re using Lion, ~/Library is now hidden by default. Probably the easiest way to access it is to use the “Go To Folder” command in the Go menu of the Finder. Select that and type “~/Library” (without the quotes) to access the Library folder.
Sync_Agent.bundle.zip (179 KB)

Sure, I’ll send it, but I don’t know what address to use and I can’t find it on the site. By the way, there are actually two files that cause problems - the sync doesn’t happen in the same order each time. I’ll try the debug sync thing now.

I couldn’t attach the log no matter what extension I tried (TXT, PDF, LOG, or no extension), and I didn’t feel like trying every possible option in the absence of a list of approved extensions, and it’s too long to paste here, so you can get it at http://davidboyk.com/files/DTTG-log.txt. I assume you already know that the attachment interface sucks.

The problem file is “Chaudhary, Creation of Modern Bihar.” Here’s what happened from my perspective: I synced, it got to that file, then DTTG crashed and I got the iPad home screen. Invisibly, the sync kept happening for a bit; apparently, DevonThink was OCRing some pictures. But then it timed out. I killed the DTTG app and tried again. Same thing happened this time, but the file came up much earlier in the sync. I tried a third time, without killing DTTG, and the other problem file, “Kumar, Image of Patna,” was the last to show up before DTTG crashed and I got the home screen. The log makes me think that Kumar might not be the problem, though, because Chaudhary came up right after that. I’ll send the Chaudhary file when I get an email address to send it to.

Sorry about that; I’ll send you a message with an email address you can use. At a quick glance through the logs you posted, nothing catches my eye as to why this would happen, so I hope the file itself can help me track this down.