DTTG Consistently Crashing

I don’t use DTTG very often, but for the last couple of weeks every time I open it, within a few minutes it will crash and disappear.

I’m using the most recent version 3.6.2. I’m using a 2022 iPad Pro with the current ipadOS. I’ve tried restarting the iPad a couple of times with no change. Syncing with iCloud, seems to do fine when it’s open long enough to sync.

Is anyone else experiencing this behavior? Any ideas what might be causing it?

I haven’t tried re-installing the app because it takes forever to sync my databases.


Crashes should be reported to our support ticket system.
In DEVONthink To Go’s databases screen, select ? > Contact Us to start a support ticket. Thanks.

Also, have you rebooted the mobile device recently?

Thanks for your response.

Yes, as I have restarted the iPad several times with no change.

I decided to go ahead and delete DTTG, reinstalled it, and now syncing. We’ll see if that fixes the problem. If it doesn’t, then I’ll submit a support ticket as you suggest.

Gotcha. :slight_smile:

This issue might be fixed in the forthcoming 3.6.3 where we worked on a performance issue. The ‘crash’ is actually more likely the iOS watchdog biting DEVONthink To Go from behind.

1 Like