DTTG crashes since upgrading to IOS 5

anyone else seeing this?

I’ve synced several times to an iPad 2 since updating to iOS 5, from a Mac running Lion. No problems.

Same here. And often it refuses to even open unless I restart the iPad.

I haven’t yet seen this, but am looking into this week. If anyone can provide anymore information, I would appreciate it.

Ditto. Had to reinstall DTTG. Haven’t been able to resync data without a crash.

Hmmm. As I recall, I had cleared my iPad2 of DT To Go databases prior to the first time I ran Sync after upgrading to iOS 5. (I do that when I need to sync from a different Mac.)

In Settings > Apps > DEVONthink > Troubleshooting there’s a Reset option, Reset at Startup, that will clear settings and the existing databases the next time DEVONthink To Go starts.

When the iPad was first released, that worked. All databases were cleared next time DT To Go was launched.

But it no longer works unless an intermediate step is taken, to Quit DT To Go. That’s because, as Apple released updates to iOS, more multi-tasking functions were added. The result is that DT To Go doesn’t Quit when you press the Home button. It remains active.

Here’s how to Quit DT To Go so that the Reset option will work and you can clear your existing database(s):

  1. Double-tap on the Home button to display the Task Bar, which will display the icons of all running applications.

  2. In the Task Bar, locate and “touch and hold” the DT To Go app icon. The icon will begin shaking, and a “-” button appears. Touch the “-” button on the DT To Go icon and it will disappear from the Task Bar. It has been Quit. Tap the Home button once more, to make the Task Bar disappear.

  3. Now, if you had previously activated that Reset on Start option above, the next time you launch DT To Go it will clear the database(s).

If you have installed and launched a number of apps, they will remain active, possibly using a bit of the iPad’s resources. You can use that Task Bar trick to Quit any non-Apple apps that you don’t plan to use soon, or don’t need to have automatically receiving data.

On iPad 2, I reinstalled, restarted, etc., (twice), then successfully re-synced my databases, from smallest (8.2 MB) to largest (4.03 GB). Or so I thought.

Then I tried to do the same on iPhone 4, and crashed on trying to sync the largest database. Now the app crashes on open.

Went back to iPad, and sure enough, it does the same.

And I will once again note that as usual, when I log into this message board and try to post, I click on Submit and it asks me to log in again - and I have to do it all over again. It’s happened twice - three times - now. Is there a pattern here?

On the third try, using the 1.2 update, I successfully completed a sync with the iPad (though the sync crashed on the last item). On re-opening, it shows the “Opening Databases” message for 2-3 minutes, then finally behaves normally. Syncing new items takes the same amount of time, even if there is only one item.

Not so lucky with the iPhone: I set it to sync overnight, which was futile, because I kept getting the “Can’t connect” error, which required a number of re-tries. It finally crashed on the last item as usual, but unlike the iPad, on re-opening it displays “Opening Databases” for several minutes, then crashes.

This is not really a useable update, given the lengthy boot and sync times. The wait is just too long.

I got better results on the iPad when I chose Tools/Verify & Repair on the Mac, and Rebuild Database where that failed. Boot time on iPad is now about 1 minute, while sync is still slow at 3-1/2 minutes for two small items - seems to take about 90 seconds to prepare, 10-15 seconds to transfer the items, and another 2 minutes to close. Plus, the app is quite sluggish when opening folders and docs; PDF viewer is better (it was completely unusable before), but there’s nothing here to tempt me away from ReaddleDocs.

iPhone is another story. After many attempts - including establishing a p2p network on the Mac - it still disconnects frequently, balks at large items, and crashes on the last item. I give up.

All in all, this update is a major hassle and a step back in most of the ways that count for me. It doesn’t make much different what the app can do with your data if you can’t get your data on it. On the iPhone, it’s completely unusable. As for iPad, its performance rates a “once in a blue moon” usability scenario - it’s still much too slow to use on a regular basis, though if I were desperate to get at a document and didn’t have access to the Mac, it would do. But much easier to drag whatever I need into Dropbox.

I’m also done posting to these forums. So tired of having to log-in multiple times and re-doing these posts; let me know when you get bulletin board software that works. Fourth try now. Bye!

You mention that you tried syncing databases ranging from about 8 MB to about 4 GB. How many databases are you syncing and what would you estimate the total size of those databases to be? Also, how much free space is available on either your iPhone or iPad?

It’s my impression that DTTG on iOS5 cashes more often after an “Open in…” than before (on iPad 1).