DTTG does not identify OmniOutliner (and other) files

I’ll discuss this with Development. Thanks for your patience, assistance, and understanding

On this topic of using OmniOutliner with DEVONthink on iOS, I can share what I do. I’ve long experienced the same problem that OO files end up as “unknown” on iOS, but then one day I discovered you can do this:

  1. go into OmniOutliner on iOS
  2. use the “Browse” function in OO (tap the Browse icon along the bottom row)
  3. select “on my iPhone” or “on my iPad” from the list it shows
  4. tap the “…” icon in the upper right of the screen
  5. select “edit” from the menu
  6. look for DEVONthink To Go in the list
  7. enable it
  8. click done in the upper right of the screen

Now you will have DEVONthink To Go in the list of Locations you can browse in OmniOutliner. You can browse the group structure of your DEVONthink databases directly from OO – they are mapped to folders in the iOS device file system. OmniOutliner naturally recognizes OO files, so they are easy to identify among the lists of documents (and of course you can tap them to edit them in OO directly).

Thanks for your input @mhucka: this shows that this problem seems general (as does @Solar-Glare’s input). But your description of your solution for the problem seems to correspond to an older version of OmniOutliner, as the latest version (3) does not have the button layout you describe. I have tried to reproduce your indications and I have not obtained any positive result either (am I making myself clear?).

Best regards.

I’m using the latest versions of DEVONthink (3.1) and OmniOutliner Pro (3.7.4) on the latest version of iOS 14.5.1. Here are some screenshots.

Opening OmniOutliner, and tapping the “Browse” icon in the bottom of the app, the following is the screen I see before I add DEVONthink as a browsing location. The icon to edit this list is in the upper right hand corner.

Tapping that icon in the upper right of the screen above, I get the screen below, from where I tap on Edit:

The next screen shows a bunch of locations with on/off sliders. DEVONthink To Go is initially off.

I enable DEVONthink To Go in that list, and tape the Done icon in the upper right, leading to this updated list of applications whose files OO can access. DTTG is now in the list.

Tapping on DEVONthink To Go in that list, if I haven’t accessed the files in a few minutes, I get a screen telling me that OO needs permission from DEVONthink to access its files. (Note added 2021-05-26: This is normal and happens because I have turned on PIN/biometric security in DTTG.)

Now, this part is a little unobvious: when I tap the “Open DEVONthink To Go” button in the screen above, it sends me to DTTG, but then nothing happens after that – I’m in DTTG normally and the system does not prompt me to do anything else, and it’s not clear if DEVONthink has given permission or really if anything has happened at all. So now I use the normal iOS method of switching applications to switch back to OmniOutliner manually (in my old iPhone 6S, it means double-clicking the home button), whereupon I discover that now OO provides me a list of my DEVONthink databases, as folders:

That’s my list of DEVONthink databases on my iPhone. If I go into any of those folders, they are exactly my group structure in my databases. I can navigate down to subfolders (subgroups) and find OO files, and edit them in OO.

Hope this helps!

Hello again @mhucka : first of all I want to thank you for your detailed explanation.

Indeed, I correctly performed the procedure you describe, and now I understand your way: you access the OO files that are identified by the iPadOS system. But all this does not change the underlying problem: DTTG still does not recognize internally the OO files and labels them as unknown.

You were right in your explanation. It serves to access the unknown files since the system identifies them, but it is something that is not uncomfortable the fact that DTTG does not identify them. The latter is what I am looking for.

Anyway, thanks for your resource.

Kind regards.

That’s right, it doesn’t change DTG’s behavior w.r.t. labeling the type of file. I only mentioned this approach as a way to work with OO files more directly even when they are stored in DEVONthink. In my case, I often know which files are in OO format and which are not, and so it’s easy to use this approach to just go straight to them.

This is true. But you will agree with me that with this method we lose the intelligence in the search that DTTG has, apart from making the management more difficult as the files grow in general. Even so, it is a good way to get out of the way for the moment! :wink:

Yeah, I agree you lose the search and other DTTG features.

BTW, are you aware that you can open an OO file directly from within DTTG using the share/send-to button? If you find one of these “unlabeled” files in DTTG and you know that it’s an OO file, select it normally, which leads to a mostly-blank screen like this example:

Tap the button in the lower left, and it will bring up a list of applications where to send the file. If OO is not one of the options in the list of applications, scroll right all the way to the end of the list of applications, and click on the “More” button. This is a normal iOS feature; it will let you edit the list of applications, and you should be able to add OO to the list. From then on, you can open OO documents from within DTTG directly (as long as you know that it’s an OO doc, of course, since, as we all know, it will show up as “unknown” in DTTG).

Yes: this is the first thing I tried when I realized that DTTG did not identify the OO files. We have resources to get us out of this situation.

My apologies – this thread had been so long that I forgot the details of your original posting :-). Now that I read it again, I see you described using this method. I didn’t mean to restate the obvious.

Don’t worry: I thank you for what I learned with you. Dialoguing clarifies concepts. That, too, is why we are in the forum.

1 Like

If you want a quick operation and sync on-the-fly, you should use OmniPresence and index needed folders to Devonthink, no need for DTTG and DT-to-DTTG sync. I index them to Inbox of a given database and replicate them and their files where needed afterwards using tags. Edits you do on your Mac are also instantly synced to all your OSX and iOS devices where OmniOutliner (and OmniPresence if OSX) is installed.

You will still need DEVONthink to DEVONthink To Go sync if you want the OmniOutliner files in the database(s) in DEVONthink To Go.

I need it in DT, yes. But for now I can’t think of a reason to have it in DTTG… At least until DTTG will be able to work with .opml or better with .ooutline

Maybe you can suggest why anyone would want .ooutline files in DTTG?

Have you, maybe, enabled DEVONthink To Go’s PIN/biometric security and set the lock delay to “immediately”?

Friends: what about the question that opened this post?

Why DTTG does not identify OmniOutliner files?

This lack makes it difficult to manage them on iOS or iPadOS from the file manager that is DTTG.

We’ve not investigated the cause of this here. What would be good would be a quick recap on how you’re bringing the OmniOutliner files into DEVONthink To Go: from the Mac through sync or are you adding them directly on the device? And just to be absolutely sure we don’t miss any details, could you share such a file with us that we’re using the correct file format and extension (it’s all important)?

To @bluefrog I was answering the questions he asked me. We also did some tests and everything is reflected in this post. There have also been two or three other testimonials reporting the same problem.

Moving on, now to your questions:

  • OmniOutliner files (both .oo3 and .ooutline) come from the Mac via sync (iCloudKit).
  • I have tried it with different content and the result is always the same: the OO file appears as “unknow”.
    -…And when I can I send you a test file through this post.

Thank you.

OK, that should be enough. We’ll see if we can somehow reproduce the issue. Which version of OmniOutliner is installed on the iOS device? And which on the Mac?

macOS: OmniOutliner 5.4.2
iPadOS: OmniOutliner 3 (205.5.0)

macOS version: High Sierra ver. 10.13.6
iPadOS version: 14.5.1

I understand that reproducing a problem that is not general must be complicated.

Thanks again.