DTTG Markdown search

I have a daily journal database that is mostly markdown(Early entries were rich text)
In every markdown journal entry is a table of the podcasts I’ve listened to that day. I generate each podcast entry using a shortcut. The table looks like so:

||Time|Show|Episode #|Title|
5:59 PM|‎WTF|1264|_**Franklin Leonard**_|

How do I search in DTTG for i.e. all the journal entries when I listened to episodes of WTF between 1250 and 1265? Even a search for just 1264 doesn’t result in the above example entry which does exist.

This would be one way to construct the search…

What are you using for a search?

This Database

This gets no result in DTTG.

Gets me one result where there is an entry for 12:56 PM but that’s it.

Searching for any 12xx number will almost always result in an entry where 12:xx is a time of day string in a file but never when 12xx is just a string.

Apologies… I was looking at and working in DEVONthink.

This isn’t currently supported in DEVONthink To Go.

What isn’t supported, searching for number strings in content or searching for a range?
Even searching for a simple four digit (1245) string returns only when the string shows up in time (12:45) format but not the plain string which definitely exists in one record.

Range searching isn’t supported.

But searching for simple strings doesn’t seem to work as expected either.

This is what I’m seeing here…

I’m definitely not getting those kinds of results.
As a test I searched
That gave me one result which had a time of day entry for 12:59 but the episode of WTF I listened to that day was 1254.
So I searched text:1254 and got one result where there was a timed entry for a podcast listen at 12:54 and the WTF episode I listened to was 1245.

Did the searches both with text: and without, same results either way.

Is there an database I should rebuild or something?

If you can’t find items in a search in DEVONthink To Go, select ? > Help > Appendix > Utility URL Commands and click the Execute link under reindex . Then quit and relaunch the application.

Done that.
Is that a background process that only…proceeds when DTTG is in the foreground?

Some progress:
I synced my iPhone, where I do most of my journal entries, to the iPad via Bonjour. Everything seems to be on the iPad as expected and I’ve never had a major problem with sync since switching to bonjour. Now for searching…

Searching on the iPad gives the results I need. A simple string with no “text:” prefix gives the expected results. (If there was a way to eliminate results where it’s finding all occurrences of 12:56 for a 1256 search I would like to know) but even 125* gets episodes 1250 to 1259 and that’s great. BUT!
doing exactly the same searches on the phone still gives no results. I’ve done that reindexing trick or at least I think I did as there wasn’t any progress indicator.
What’s the next thing to do get this working? Reinstall?

I have still not been able to get search to work on iOS for my phone. I can search for 1265 or text:1265 in a database and get no results even though I know there’s one record that has that string exactly.
If i search for 1255 i get a few results with time entries of 12:55 but not the one record that has the exact string 1255 in a table.
I’ve done the Utility URL reindex command.
Searching works fine on the iPad. Same level of OS and app.

What happens when you change something little, like adding a word, and sync from the Mac again to your iPhone. Then wait a moment. Is the document now findable? And: after entering the search term, did you press the Return key? The full-text search is only kicked off after pressing the Return key or tapping the Search button.

This I am always doing. It tripped me up back in the day but not now.

This worked for one record that I adjusted on the Mac. (added some text to a journal paragraph).
Sync on Mac
Sync on Phone
Search on phone for 1265 and that newly modified record shows up as the only result.

So how do I do this without having to modify each record manually?

FYI if I can get this to work on my phone the NEXT question I have will be how to NOT get records back from a search that have colons in the result. i.e. ignore all the 12:55 results for when searching 1255

It seems that the data sent from the Mac to iOS was incorrect or incorrectly processed. The best option would be to remove the data from your iOS device and sync it again. This deletes the on-device index and retrieves everything completely fresh from the sync location.

This is a hardcoded mechanism that replaces some characters inside words, like commas or colons, with a phrase. For example, 1800:7473 becomes "1800 7473" to make finding it more flexible.

To clarify: remove the sync data, i.e. clean out the sync store? Or remove the database from the iPhone and resync from Mac?

Next question:
99.999999% (+/- 0.0000001) of these records in this particular database are created by shortcut on this iPhone, then modified each day by me via direct text editing and shortcut generated clipboard paste editing. Up until your above suggested workaround the most I’ve ever done on the Mac to these records is add some tags.
How is it that the data required for search to work on the iPhone is not being written anew with each new entry? I do not code but I would have thought the problem would have been reversed in that, after a problematic synch, the search wouldn’t work on devices where the records had been synched to as opposed to what I’m seeing which is that search works on two devices neither of which were used to create or edit the records. Just curious.

So, is it possible to search and eliminate results with a colon? i.e. to force it to only return the exact numerical string?


To clarify: remove the sync data, i.e. clean out the sync store? Or remove the database from the iPhone and resync from Mac?

I believe he’s referring to removing the database and reimporting it.

So, is it possible to search and eliminate results with a colon? i.e. to force it to only return the exact numerical string?

Not at this time, no.

The idea would be to remove DEVONthink To Go from the iPhone, reinstall it, and resync. However …

Actually, they are. When you change a document in DEVONthink To Go the document should be reindexed automatically. There were bugs in the past that kept it from doing so so maybe if a document is older it was indexed incorrectly. When you now changed it on the Mac it was indexed there and the indexed text sent back to your iPhone.

Of course there could also be an issue with local indexing in DEVONthink To Go. Could you run a quick test for us? Create a document with Shortcuts. Wait one, two minutes latest. Now search for it. Is it found?

At the moment unfortunately no.

I create a markdown document via shortcuts every day. Only two days ago I tested this by looking for a number string that I had just entered. Just did it again. It was not found. Searching for a text string that I know repeatedly exists (WTF) only finds the tag that also matches the string.

Part of this quest has been powered by the fact that for the past month I’ve mostly been using a work computer while my own laptop where DT exists has been languishing. Before I take this step I’m going to ensure I have working backups of my iOS-centric databases.