DTTG not finding all search results

If I do a search like “foo and bar” in DT3, I get 20 results. Yet, the same search in DTTG only gives me 9.

The documents include DOCX, DOC, PDF, and .PAGES documents.

The pages and pdfs seem to show up, but none of the others. Is this a limitation in the search or in DTTG itself?

(I have purchased the “Pro” upgrade to DTTG.)


On which device did you import the files which are not found - Mac or iPhone/iPad?

DTTG is not finding files (like doc, docx) on iPhone after sync and indexing.

And these files were synchronized from the Mac to the iPhone?


  1. Set up iCloud sync on mac (DT3)

  2. Setup DTTG Pro on iPhone (iOS 13)

  3. Import databases on iPHone

  4. Wait until all indexed.

On iPhone search results less than Mac on same data (9 vs. 20). DTTG missing file types it seems.


Also, as I see here on using search in DTTG:

This syntax (in DTTG on the iPhone) didn’t find a match in a word document where “Twitter” and “REST” were three words apart:

NEAR(Twitter REST, 10)

The case described above where DTTG is missing all kinds of search results on the iphone, however, was just a simple AND.

Would you mind sharing these documents with us, maybe, by email (or direct message here)? We’ll treat them confidentially, of course, as we’re mainly interested in why they would not be found.

Here’s an example.

Create a DOCX with this text:

“This is a test. A little brown fox ran across the road.”

Try, in DDTG this command:

NEAR (brown ran, 4)

(annoying the syntax isn’t the same.)

I find zero results.

I don’t know why DTTG missed so many files with a basic AND query in that other database I was posting about (sorry, no, can’t share those proprietary files), but I don’t have all day to investigate.

That database was large. Over 1 GB. I realize that size is nothing that DT can’t handle, but perhaps it’s related somehow.

It’s been a disappointing experience and I will probably request a refund from Apple.

Here’s another example with just a text file.

I have a log file with details about what method a client runs on their computers (yes, this log has the client’s permission and knowledge).

There are lines with “Log usage” followed by different types of usage.

In DT3 on the Mac, the line below correctly finds the log files.

Log item [A-Z]*SendLogic

However, in DTTG, the same command finds … nothing. The log files are there. Perhaps in this case DTTG doesn’t support the same operators, which, if true, is more frustration. Not sure about this, but search is what I need to work perfectly and it doesn’t or at least not as expected.


Perhaps in this case DTTG doesn’t support the same operators

No, DEVONthink To Go doesn’t support all the same operators and prefixes as DEVONthink 3, so of course the results can vary.

I’m not seeing any issue with finding .doc(x) or text files.

Try this:
Select Help > Appendix > URL Commands > Performing Service Tasks and click the Execute link under reindex. Then quit and relaunch the application.

Tried that, but no, it does not work.

I have a text file with “Log Usage” (words next to each other) as text in it.

I do a search: NEAR (Log Usage) and nothing is found.

Log Usage (without the near) is found.

The other example I posted above for a simple search in a Word document is not found either. If DTTG doesn’t support a search operation, it should give an error, not display nothing (this isn’t a case where “failing silently” is desired). Of course, based on what I read, I believe my Word example should work too, but it doesn’t on a one line word document.

So, 9 documents found on DTTG and 20 on DT using a simple “AND” search.

Not sure what to do except get a refund as this product doesn’t seem to work for me.


As I was removing the DTTG databases prior to refund, I noticed that DTTG did not seem to remove the storage from iCloud (I waited overnight to see if the data were freed back up). I had to go into iCloud and manually “Delete Data” for DTTG – globally. In this case, that’s fine since I’m no longer going to be using it.

Not sure if this is another DTTG bug or if it’s just how iCloud works and you have no control over it.


Thanks for your replies.

That is how iCloud works. We can’t access Apple’s servers directly.

Did you try my suggestions where DTTG did not find a match (but DT did)?

I could send you files offline to test, but at the moment, I do not have DTTG to test further here.

My failed cases included a simple text file and a simple DOC file with one line of text.

If you can fix the problem(s), I would repurchase.


Did you try my suggestions where DTTG did not find a match (but DT did)?

Yes, I tested the search with the NEAR operator as you were describing it (see the screencap above). I had no issue finding the document in either of our apps (though obviously the syntax differs).

I don’t know about your documents but I could send you two documents that didn’t work. Simple DOC file created in LibreOffice. Same with a text file. You seem to be dismissive of this issue. I’ll be glad to help, but I’m not posting documents on the public forum.

Also, I had about 10 other documents that didn’t match in the database in question. 9 found in DTTG and 20 found in DT3 using the same simple “term1 term2” query type. That’s not good.

I would like to figure out and resolve these issues. In that case, I would happily re-purchase DTTG.


Start a support ticket and attach any appropriate documents.

A short test with a text file worked for me:

It worked for n=2 and n=3, but not with n=1, which is correct.

I gave a specific example above using LibreOffice saved as a DOCX. Your example is not representative of that test.

In my case, DT3 found 20 matches with another “term1 term2” query, yet DTTG only found 9.

I sent a test file to DT support folks last week, but have yet to hear anything back.

Unless they find a problem, it’s clear I shouldn’t use DTTG since it did not work correctly for me.

Thanks for your quick, though non-representative, example.