DTTG not finding content in markdown documents.


I’m using DTTG to capture vocabulary words (as document titles) along with their definition (the document content) in markdown. When searching for content in the definitions DTTG does not return any results. (Although, I can find the documents by their File Names and Comments.) I’ve performed the ‘reindex’ service task, but the problem persists.

Is this expected behavior with markdown documents in DTTG?

Running DTTG 2.2.1 running 9.3.5.


There was an issue with plaintext formats not being searchable. The next maintenance release addresses this.

PS: iOS 11 is here. :wink:

Note: You might need to reindex your database (see embedded help, chapter Appendix > URL Commands), only Markdown and plain text documents created or saved after the update to version 2.3 will become correctly reindexed.

Haha! Still on iOS9!

Thank you! The update and reindex solved the issue.

Glad to hear it.

Although a reindexing worked, new markdown documents after the update to 2.3 are not searchable by file name, content, or comment even after a restart of my iPhone 6. I’m not sure it has any bearing, but I’m creating the markdown file via url scheme with Workflow.

I have over 5500 items in my db’s and having to reindex them after markdown/plain text documents are added will prove to be very cumbersome. Any ideas? Can you or BLUEFROG reproduce this bug?


I’m not seeing any issue with newly created Markdown docs. Open a support Ticket and provide what you have for the Workflow you’re using.

Thanks, BLUEFROG. I just created a support ticket with a link to the Workflow. Fyi, I explained the following in the aupport ticket:

“Upon further testing I’ve discovered that creating markdown documents via an url scheme from Drafts also produces a file unable to be found (properly indexed) upon creation. I further tested this hunch with a base64 encoded pdf via Workflow and got the same result. So I’m suspecting the url scheme route is the culprit here.”

Can you confirm this anomaly with a markdown or pdf to DTTG 2.3 via url scheme?


Confirmed and an issue has been filed. Thanks for the report!

Thanks for confirming, and no prob!