DTTG not updated after iOS 11 is installed


after updating to iOS 11, update of Devonthink To Go to 2.3 is not possible for me. My iPhone and iPad has 2.2.1 and the list of available updates for all my apps does not show 2.3, in fact when I look DTG in the App Store, next to the App the button is Open and not Update.

Phone has been restarted, synced with my iMac, still no change. If reinstalling and syncing would not take that long I would not mind but with a database of 22Gbytes it matters…

Any idea?

I had the same issue – I was on DEVONthink 2.2.1 when I installed iOS 11 and, afterward, a day later, the App Store insisted I was on 2.3, when I was actually on 2.2.1. In other words, no way was I going to be able to update 2.2.1 to 2.3.

… After having the same issue on a second iPad, I can confirm that logging out of your App Store account and logging back in will force the App Store to recognize that DTTG has not been updated to 2.3 and will offer it for update. App Store bug, no doubt.

You are right, this is an AppStore problem. Tried to logout many times but still no resiult. Need to reinstall :blush:

We are using a “phased rollout” so that the automatic update doesn’t kick in for all users at the same time. However, the manual update should always work. If it doesn’t then it’s probably an App Store issue.

Manual update of the app on iPhone and iPad? How should I do that? Thanks!

The problem is that manual updates do not work unless one either deletes and reinstalls DEVONthink to Go, or logs out then logs back into the App Store. I have not seen this issue with any other app – and have had dozens updated in relation to the iOS change.

Turn off automatic updates in Settings > iTunes & App Store > Automatic Downloads. Then open the App Store and refresh the Updates pages to see the list of apps that need updating. Choose the app and press Update.

I just did the opposite as automatic download was off. So, I made it on and updates are showing up! Thanks