DTTG on iPad pro with Synology Diskstation

Good evening, most probably I simply don’t get it. But I have problems to set up DTTG on my iPad.
I am using a Synology Diskstation NAS at home. DT on the iMac or Macbook access the databases stored on the NAS without any problems.
I just installed DTTG on my iPad pro and tried to set things up.
I installed and activated the WebDAV service function on the NAS.
I activated the HTTPS function.
The database is located in a folder like this: 192.168.1.xxx/home/DEVONthink/XYZ.dtbase or.dtcloud
So I tried to add a location in settings/WebDAV.
For address, I used “https://192.168.1.xxx/home/DEVONthink/”, entered my usual user name for the NAS and the corresponding password, put XYZ as the sync-store-name.
Now there are some error messages concerning certificates, aliases, whatsoever. And in the protocol, I get a “authentification failed” report.
Is there somebody in the community with a similar setup at home with some helpful hints to solve my problem? Any idea is highly apprecitated.
Many thanks and greetings from Germany

First off, did you read How to use Synology NAS as sync store? It should describe how to set up a Synology NAS as sync store via WebDAV.

Secondly: your description a bit confusing.

  • What is your NAS’ IP address? (Frankly, there’s no point in disguising a private IP address with something like “xxx” – that’s more confusing than helpful).
  • What do you mean by "the database is located in a folder like …? This seems to be a networked folder, but it is discouraged to put databases on anything but a local disk (note: I’m not talking about sync here but about the location of the database!)
  • What is the name of the folder you want to share on your NAS? A screenshot of your Diskstation’s layout might be helpful here.
  • Did you set up a user who has read/write access to the folder on your NAS that you want to access via WebDAV?
  • Did you change the default port of WebDAV over HTTPS?
  • Can you connect from the Finder with “Go to server” and "https://:5006/ and your username/password for the NAS?

This is less than helpful. If there are relevant error messages, post them. If the error messages are not relevant, why mention them at all?

Which protocol, where? Mac? NAS? somehwere else entirely?


Good evening, thanks for the quick reply. And sorry for the lack of precision in my post.

  • Yes, I read the description how to set up the NAS as sync store.
  • My idea was to only sync the iPad at home in my home network and not remotely via the internet.
  • The NAS IP is, the given name is “Wolke70” (cloud 70) there are several users with access to own or shared folders or volumes.
  • On the iMac I can “Go to Server” and usually access it with SMB: or SMB:Wolke70 I originally put the database there to access it both from the iMac or the Macbook and that works flawlessly.
  • The location on the NAS is home/DEVONthink.
  • I did not set up any new user, I just thought - most probably too naive - the existing user/password and access priviliges would do.
  • When I try to access via https:// in Finder, I first get the error message (in German) that the certificate is invalid and from an unknown source. I might be connected with a WebDAV server pretending to be the given IP address… if I try to connect anyway, it fails.
  • Access via Firefox works fine with the https though.
  • I did not change any port number. Here the screenshot from the WebDAV app on the disk station:
    Sorry again, I did not mean “protocol”, i meant the error message in the DTTG iPad app. When touching the cloud symbol in the lower left corner of the main screen I get the message that the authentification failed…

I’m not following the entire thread, but I’ve seen a capture:

Please, please, don’t put your Database inside a network share, it is a candidate to have a lot of problems, apart of dramatic slowness.

In you case, Synology is only for the SYNC Database, and your database in your local Mac (or a mounted local disk).


Again: Storing the databases on a network drive is discouraged. Another person reported problems with this setup just some days ago. You might want to reconsider this.

As to the NAS:

  • Connecting via SMB shows that SMB is up and running.
  • From the screenshot I’d say that you are using the correct location “/home/DEVONthink” in your connection
  • It is not really necessary to set up a new user. But the one you want to connect with has to have read/write access to the location “/home/DEVONthink”. Which should be true for any administrator, but it might be worth to check (Systemsteuerung - Gemeinsamer Ordner - home: tab “Bearbeiten/Berechtigungen”).

Now to the HTTPS problem. If you connect via finder, you must use port 5006, like so:
If you get the certificate error, did you follow this procedure to create the certificate: https://www.synology.com/de-de/knowledgebase/DSM/tutorial/Network/How_to_enable_HTTPS_and_create_a_certificate_signing_request_on_your_Synology_NAS
Please try to connect from your browser to your NAS like so
does the browser complain about a bad certificate, too? Please check the details: In my case, the certificate (by Let’s encrypt) was issued for my Synology DDNS server (xxx.synology.me). In that case, the IP address (192…) does not match the name in the certificate, which makes the browser (and probably the finder, too) reject the certificate.
If it’s the same problem in your situation, try connecting with your Synology DDNS name:
https://yourname.synology.me:5006/ in Finder’s “connect to server”, https://yourname.synology.me:5001/ in the browser.
Does that work?


Thank you very much for your advice and patience.
I will reconfigure the entire idea and put the database off the shared drive.
I’ll try to set up a sync on the shared drive and thereafter try to connect my DTTG directly to iMac or Macbook.
But just for the initial mindset I’ll give it a try and follow the WebDAV idea just to learn if it would have worked…
If it does, I’ll let you know, might take a while as I am away from home for the next week or so.

It seemed too easy and it was truly intriguing and tempting: buy the app, hook effortlessly onto your running system, sync in no time, take your files with you…

But thanks again for your time and expertise. Sunday night in Germany, Greetings…

Do note: If you’re using a self-signed certificate on the Synology for WebDAV, DEVONthink will prompt you about it. However, it allows you to okay using it then DEVONthink should be happy with the connection.

PS: Here’s a working SSL WebDAV sync with a Synology NAS on my local network, using a self-signed cert…

Just another idea: since you’re in a local network anyway, you could go for HTTP instead of HTTPS.