DTTG over mobile data

I have a database synced with iCloud between my Mac and iPhone.

On the iPhone I have it set to download on demand, which works fine via WiFi. However when on mobile data DTTG seems to refuse to sync or download any documents.

Mobile data is enabled for DTTG, and mobile data works fine for all other apps.

I’ve tried disconnecting and re-enabling the database, uninstalling and reinstalling the app but still the same problem.

Latest versions of the applications on both devices. Late 2013 MacBook Pro, and iPhone SE.

Does anyone have any ideas? Have a missed a switch in the settings somewhere?



I just get the spinning wheel. I left it for hours and no change.

In your last image, you have Global Inbox sync turned off.


Sorry I should have made it clearer. It is a separate database I’m trying to sync. Attempting to connect via mobile data does not even show the database.

This is the screenshot now I have let it sync and index via WiFi. However, if I go back to mobile data only I cannot sync or download any files on demand.

Does this persist after rebooting the device?

Yes, tried rebooting several times, but no difference.

It’s possible iCloud has stalled. Select Help > Contact Us to start a support ticket. Thanks.

Thanks for the help. Your comment about iCloud stalling got me thinking.
I signed out of iCloud on my iPhone, and then signed back in and now DTTG syncs fine over mobile data.

Glad to hear it! And yes, this is what I would have suggested.

iCloud is definitely convenient, but it does have the potential to stall like this. It’s nothing we can control over detect, since it’s under Apple’s control.