DTTG PDF Clipper?

How is the updated clipper in DTTG supposed to work? I don’t find any PDF options when I clip, and if I use the iOS print, then pinch to expand into PDF and clip that, only the first page is in the PDF – all other pages are blank.

The 2nd time I ran this sequence did capture all pages of the PDF (same web page, same procedure).

(3rd edit) And it doesn’t capture the source URL.

You can clip e.g. a web page to webarchive or plain text, or images to images. You can also print, then pinch to expand into a PDF, then clip. This should clip all pages, actually, because all we do is take the created PDF and store it. Is the pinched PDF okay, all pages there? And from which app do you try to clip/print?

The source URL is never captured as Safari doesn’t deliver it.

They are now. The very first one I tried after the update only had the first page, with all other pages blank, but it was only that first time.

Safari (iOS). Other than the missing URL, all seems to be working now.

Just curious, why is there no PDF option within the “Clip to DEVONthink” popup?

Like saving a web page directly to PDF? That’s also on our long list as it’s not just a few simple lines of code :slightly_smiling_face:

1 Like

+1 for Saving Web Page to PDF in iOS
Also, please allow saving PDF from Safari in iOS. It is convoluted to have to Print>Adjust>Then Save.