DTTG won't sync

Downloaded DTTG. Put 1 document into the sync group for a DB. On DTTG i select the sync icon, and it brings up a window which says “please select a computer on your local network”, there is only one shown the only other option is Reset Synchronize Settings. Cancel does not work, it just stays on the screen, i have to stop the app and restart.

Could this be a firewall problem on my mac

ok… so i have no idea what i did, but now sync is working

The issues with the ‘Cancel’ button has been reported and will be fixed in the next update. There do seem to be issues with DTTG discovering the desktop computer - we are looking into this…

If you are running an anti-virus program like VirusBarrier X6, be sure to adjust the settings to ensure your Mac can actually talk to your iPad–that was my problem. Appears to be syncing normally now. :slight_smile:

Hello Pet, I have the same problem and also X6 running. I’m not able to find the magic switch and get the sync going. Can you tell me where you configured X6 so DTTG started syncing. Thank you.

Good to hear this.

My syncs worked 2 times, now I do not get my (only) desktop computer in the dialog. There is no choice, and the Cancel button does not work…

I thought it was Bluetooth because Goodreader seems to have had problems of this kind, but putting Bluetooth off did not work either.

Can’t wait for the bug fix.


System Preferences…

Make sure DT is set to allow incoming connections.


it is nothing with the firewall. After some more trials I got a very sloppy connection, which was broken several times, mostly because of DTPO crashing.


Changing the firewall setting worked for me. Thanks

Glad to hear it. :smiley:

I’m going to jump right in here on this conversation …

I just installed DTTG on my iPhone 5s. Everything in the DTpro database seems fine, and I’ve moved a few test files into the mobile section.

However, my iPhone does not pick up the any databases. I keep getting a “Bonjour Failed” notice.

I’ve tried the suggestions in the thread listed above, but no luck.

Any other suggestions/wisdoms/solutions would be greatly appreciated.


  • Mike

My first advice is always the firewall setting, to allow incoming connection for DT. But that was in the thread, and you’ve tried all that.

In the past, when I had some intermittent problems, it sometimes was necessary to restart/reboot everything on both the OS X and iOS sides of things.

Additionally, if you are currently using a connection through a wifi-router, establish instead a direct Mac-iPhone connection via an ad-hoc network (in the wifi menu bar item, choose “create network” at the bottom). You can also try to make the connection via Bluetooth.

Thanks gg378, it finally worked when I got off my school’s network, and used my home’s wifi.


@coachmike: Administered networks can block Bonjour (or unknown Bonjour devices) as well as any non-standard ports. This is beyond our control.

Thanks Jim,

Then can I ask, do you foresee a different syncing process in the future for DT pro, like iCould, Droop, or other method. I’m asking because I work predominantly on Administered networks.

There will be new options in the next major release of DEVONthink To Go. Stay tuned. :smiley: