DTTG3: CSS-Style for Markdown is not recognized

Hello,

I have a custom style css for Markdown that is recognized with Devonthink To Go 2 and on the Mac.

With Devonthink To Go 3, this is not recognized and applied on the iPad and iPhone.

Matthias

How do you define the CSS: with a link (whereto?) In the MD file or in the DT settings in the desktop app?

I define the CSS with a link in the MD file:

Which looks like …?

Using DTTG2 and DT3 on Mac is working

Style_mk.css.zip (1.4 KB)

Meine Frage war nicht, wie das CSS aussieht, sondern wie der LINK aussieht.

My question was not “what does the CSS look like” but what does the URL look like.

Anyway, I just tried in in DTTG 3 like so

css: x-devonthink-item://0841105D-70B7-4518-8E2C-68E25CF8FC38

as the first line in the MD file. That does work.

This syntax is working. Thanks

I’ve used this link:

<link rel="stylesheet" type="text/css" href= "/x_Vorgaben/Style_mk.css">

I’m not seeing an issue with the link method. Is the x_Vorgaben group in the Inbox or the root of your database?

1 Like

The x_Vorgaben group is in the root of this database. And with DTTGO 2 and DT3 the link method is working; using the same files.

Does this persist after rebooting the iOS device?

Yes, this persist after rebooting the iOS device

Forgive me if this should go to a new thread, but I’d personally love to see support for setting one CSS style as a default for all MD files (like you can on the mac).

1 Like

Welcome @ehler

No worries!
Are you able use the link syntax as is being reported here? I’m seeing no issue with it.

Haven’t tried; my request is to be able to set a global CSS on DTTG rather than adding this line to each MD file (though I suppose there’s a way to script/shortcut it’s addition automatically). Obviously this isn’t a fast-turnaround request, just something for the roadmap.

The request is noted but please try using the condition being reported as not working and let us know whether it works for you or not.

Did you found a solution with <link …> for css working?
On my DTTG3 it’s not working too. On DTTG2 it was no problem.