DTTG3 database empties out?!

Synced via Cloudkit.

I’ve been reading on my iPad, switched to Safari for a bit, went back to my pdf in DTTG3 and it’s no longer open, and my database is suddenly empty, shows 0 file count and when i attempt to sync it the cloud icon briefly turns blue on far left corner but that’s all - no error message, no other changes to the sync icon, turning the app and sync toggle off and on again hasn’t changed a thing.

Are the databases still there on the Mac? Do you see any error messages? In doubt please send us email from within DEVONthink To Go by using ? > Contact Us. This attaches the log files.

Just a silly idea…: you haven’t somehow still got DTTG2 on your iPad and are opening that rather than DTTG3 (because iOS offers you up the icon in Siri suggestions, for example)?

Otherwise: have you turned it off and back on again?

I’ve sent you a request from within the app. Honestly I was hesitant to check things in DT3 out of fear of loosing my contents, if you think it’s necessary I’ll take a look.

I do still have it, but no, definitely haven’t opened that instead. I switched back between apps, and the recent files list shows content that was synced (that I was just reading) and it’s a database that was never synced to DTTG2.

If you’re worried, simply make a copy of the DT database file(s) on the Mac and put it/them somewhere safe before proceeding.

1 Like

So the zero-byte documents are from a database that was never synced to DEVONthink To Go 2?

Eric, if I read the original post correctly, then the problem is not empty files, but no files:

Alright, DT3 tells me there are 3 missing files: two being indexed pdfs that I added yesterday to the index location and have just checked - they’re still there, nothing seems to be an issue with them on their own. The third is a rtf created within DT3 that I have not touched or opened in months.
The funny thing is, I ran the Verify and Repair on DT3 just yesterday because of previous issues with Trash (emptying Trash solved the “missing files”), so hours before my database emptied out on DTTG3 and subsequently 3 files missing on DT3, all was well according to Verify and Repair.

Indeed. Here’s a screenshot.

This looks very much like a sync issue that we’ll need to investigate.

The folder with the PDFs in question (that DT indexes) is located on iCloud Drive - could that be part of the problem?
I don’t mind moving it, I only put it on iCloud when Mendeley pulled the plug on mobile apps as a way of having my library accessible across devices before DTTG3 came out. If you’d recommend I move it back locally, do I need to then delete the index group from my database before reinforcing the new location, or is there more to it as far as DT3 is concerned?

Hmm, it could well be. But, actually, that is something @cgrunenberg would need to comment on. He’s on vacation this week so I’l assign your ticket to him and he’ll surely get back to you as soon as he is back at his Mac early next week.

This shouldn’t be an issue. Or was the folder recently renamed by you or another app?

I hope it’s alright I’m responding here - the original issue was resolved, however I just got another instance of DT3 database verification telling me I have a missing file, referring to an indexed PDF originally located in a folder on iCloud.

Since I no longer have a specific reason to keep that folder on iCloud, I’m thinking of moving it back locally (thinking it might prevent similar issues from happening), but wanted to check if there’s a best-practice approach to moving an indexed folder from DT3’s point of view?

Same thing happened to me, it’s probably a sync issue. Fixed it by doing a bonjour initial sync then continue updates with CloudKit.

I still get missing manifest errors once in a while, in DTTG, but as I said before in another post, I don’t know what that means and just clear the log.