Easy Find and International characters


As far as I can tell easy find doenst seem to be indexing international characters when searchin my smb mount.

It find a word document containing the word “gava” but not the same document containing the word “gåva”.

Is this a known deficiency in Easy Find or am I doing something wrong?

EasyFind treats all files as plain text and therefore searching for international characters in proprietary file formats (like Word docs) does not work.

Thank Christian, prompt and quick as always with an answer. Just to check the veracity of your answer i created umlaut.txt and put in the word “jönsonligan” and did a search for that term on my computer.

I was greatly surprised to discover that .txt is a proprietary format. I will immeadiately stop using the txt format :stuck_out_tongue:

But seriously - there seems to be something wrong with my easyfind. Since it wont find the term in a common txt file.

I have tiger 10.4.6 by the way

Ah it appears to be an encoding issue … and I really really really hate encoding problems… :imp:

There is no easy solution to this one. I have files in all kinds of encodings on my computer, what should EasyFind do? Trying each and every encoding on each file is not a good solution. People would complain that it is so much slower than . :slight_smile:
Trying to open files with the default encoding of your account would be the best choice in terms of performance and general user expectation. I’m not sure if Christian meant that by his reply. :wink:

Thanks anard,

curious question, but what does Easy Find do? Does it use the default encoding for the account? If so how does it determine the default encoding? can settings in bahrc or bash_profile affect East Find and if so which one is it LC_ALL or perhaps LC_CTYPE … just trying to figure this out :slight_smile:

Thanks again

EasyFind uses the default system encoding (usually MacRoman on western systems) but also recognizes UTF-16 with a BOM (byte-order-mark).