Editing indexed file – integrating nvalt with dtp

I have recently been collecting my notes in nvalt, which are saved in Dropbox and indexed in DTPO. I understand that this is fairly common.

How do I go about changing a note?
It seems that whether I edit it in DTP or in nvalt, the changes do not get brought across to the other application.
If I edit in nvalt, the change is reflected in the Finder preview (which confirms that the Dropbox sync worked), but not picked up in DTP. It looks, to these amateur eyes, as though DTP’s update index feature does not recognise that there has been an edit.
Any advice?


Are you sure you’ve indexed the right folder?

Over here, when I make nvAlt changes and/or DEVONthink changes to the indexed notes, the changes are updated in the other. Just did this seconds ago. Sometimes you need to click away from a note and back again if that note has been modified in the other program. Sometimes you need to force an re-indexing by selecting the indexed nvAlt data folder in DEVONthink and use File > Update Indexed Items.

Yes, I am sure that I have indexed the right folder. In fact, when I edit notes in nvAlt, the changes show up in Devonthink. And when I edit a note in DTPO, the change shows up in nvAlt. What seems to confuse matters is editing the note title in DTPO. I edited some titles this morning, and they have still not shown up in nvAlt. In fact, the note itself appears to become invisible to nvAlt.

Interestingly, the note whose title has been changed in DTPO shows up in spotlight, as a Devonthink file, whereas the notes whose titles have been changed in nvAlt continue to show up as plaintext, with the default editor icon showing as Byword.

Am I to understand that I cannot edit note titles in Devonthink? Why would that be?


I can change Name (i.e., “title”) in DEVONthink and the change appears immediately in nvALT. (There should never be a noticeable lag between making a change in ether DEVONthink or nvAlt and seeing that change in the other application.)

Perhaps you should open a Support ticket since the problem seems to be different than what the Forum can address.

I can report that it is working again. Perhaps in the OS upgrade something weird in my system got sorted out. Who knows? Anyway, now it’s working as expected.



Reboot == the cheapest available tech support

Amen! :smiley: