El Capitan mail drag and drop broken?

I’m on the latest El Capitan beta, and drag-and-drop between Mail and DTP seems to only work if the email is in the inbox. Dragging from archived email or filed email doesn’t work and gives no error. I can drag them to the desktop and then into DTP, but not directly. Anyone else experiencing this?


Just tried this myself, dragging an email from my iCloud Archive folder to the Global Inbox then another from the Archive folder to DEVONthink’s Dock icon. In both cases, the email imported fine. Only difference here is that I’m using DEVONthink Pro Office, but I don’t think that would make a difference when dragging an email.

Hmm… potentially, since DEVONthink Pro does not index emails.

Note to self: Update to latest El Cap beta.

Not related to this issue, but it would be nice if we could develop a DEVONthink lexicon that distinguishes between the process of indexing the contents of a document, for search purposes, and the process indexing documents from the Finder, as opposed to importing documents into the database.


It can get a bit confusing, I admit. I’ll ring the bell in here and see if anyone comes to dinner. :mrgreen:

I’ve done some further testing based on your comments. First I downloaded DTPO, and it performs exactly the same way. Then I tried dragging some emails from my iCloud email. It seems to work fine with all mailboxes in the iCloud account, but only with the inboxes of my other IMAP accounts.

What’s the actual, localized name of the account (e.g. Gmail) and the source mailbox (e.g. Drafts)? This seems to fail over here under rare circumstances due to a bug (?) of Apple Mail returning invalid mailbox names in case of the German localization. In most cases (e.g. local mailboxes) it’s working as expected. However, I’ve just fixed a bug of DEVONthink that broke importing of dropped emails without a subject.

It affects multiple mailboxes (Archive, any number of ones I’ve made up with project names) and multiple accounts (Mailing Lists, Bulk). I checked in the console and if I drag from any of the Inboxes of any of my IMAP accounts, or any mailbox in my iCloud account, there is no message. If I drag from any mailbox other than the inbox of my IMAP accounts or iCloud, I get this in the console:

9/4/15 10:45:07.432 AM DEVONthink Pro[17994]: on getMessages: {
NSAppleScriptErrorBriefMessage = “The variable theMessages is not defined.”;
NSAppleScriptErrorMessage = “The variable theMessages is not defined.”;
NSAppleScriptErrorNumber = “-2753”;
NSAppleScriptErrorRange = “NSRange: {448, 11}”;

Then, the next time I try to drag from inbox or iCloud, I get two messages in the console:

9/4/15 10:49:13.856 AM pkd[309]: UNINSTALLED:com.devon-technologies.think.share com.devon-technologies.think.share(1.0) 6C2DB8C4-7F37-4EBF-99C0-2E22BE5FF56D /Applications/DEVONthink Pro.app/Contents/PlugIns/DEVONthink.appex


9/4/15 10:49:13.868 AM pkd[309]: INSTALLED:com.devon-technologies.think.share com.devon-technologies.think.share(1.0) <__NSConcreteUUID 0x7fdddaf2b2b0> 296B803A-689B-4126-BDD6-1A4A406D42C8 /Applications/DEVONthink Pro.app/Contents/PlugIns/DEVONthink.appex