Email body URLs don't resolve

When adding an email to DEVONthink, the URLs in the body of the email are (no longer) clickable (in DEVONthink). Is this a bug, or something I can fix?


If I do this:

Just log out and in again and ensure that DEVONagent and DEVONthink are installed in /Applications.

Will that help?

And how do I install those applets?

In the icon bar above the email message body display, click the second icon from the left (tooltip is “Text View/Preview”) to get an RTF version of the message with all links clickable.

-----^ Click the second icon

Doesn’t work.

OK, my apologies: that DOES work if the item has been opened. But only on certain emails! (The ones where the link has been “resolved” into a clickable link in the original email.)

Still trying to figure this out. I want it to work!

Well, as a last resort, the email can be opened, click the icon for Text View/Preview, the URL selected, right-clicked, and then click on Open URL.

That’s 5 steps—seems like a lot.

Email messages from Mail are captured into DT Pro Office in their native file format, and displayed using Apple’s Quick Look plugin for Mail messages. In this view, hyperlinks are not clickable and text cannot be selected/captured to the clipboard.

One click on the little ‘Text’ button in the navigation bar above the message display switches to a rich text view of the message. In that view, hyperlinks are functional, attachments can be opened and text can be selected/copied.

Whoa! I just imported a Mail message with cickable URLs to Web pages under OS X 10.6.3 and wonder of wonders, clickable URLs in the Mail message are functional, clickable hyperlinks even in Quick Look. (But the From and Two links are not functional in Quick Look).

Finally I could resolve that issue with Emails not being able to get the content or links.

That said I would request the following:
a) Make it possible to use a keyboard shortcut to switch
b) Or make it possible to switch a selection of emails (like all)
c) Or make it possible to set a flag that all emails should be displayed in either way (preferable).

Cheers - Andy Schaefer