Encryption key not available

I’m using DTTG on my iPad and iPhone and DTPO on my Mac. Syncing via Dropbox has been working great for months. This morning I get a message on notification on my iPad that says “Encryption key not available.”

I tried to find a place to reset the encryption key in Settings/Locations, but can’t find anything.

Any help is greatly appreciated!


Settings > Locations > Edit, click the location name and edit the key.

I have the same issue today with my iPad only (iPhone works still fine).

Both database (two sync stores - one via dropbox, one via WebDAV) were not able to sync. Dropbox sync store errors states that the encryption key is not available. The message for the WebDAV just says “Informative”.

I have had to delete both locations and have done a fresh set up. Now both databases are syncing again.

Very strange - I have no clue what happened…

Did you try reentering the key as korm suggested? That should have been sufficient.

Since I could not paste in the encryption key for the Dropbox sync store, I assumed entering the encryption key did not work at all. After the fresh set up of the location, I realized, that I have to type in the encryption key. So, it might have worked without deleting the location.

The WebDAV was a different problem, because that sync store has no encryption key and from the error message I got no clue, what was the problem. After the fresh set up it took a couple of hours before syncing started working again.

But it’s strange that both sync stores failed to sync on just one device out of the blue and someone else had the same issue around the same time…

Yes, I’ve also noticed that when it rains in Madrid, other people get wet at the same time. Odd coincidences.