Entourage email import: strange behavior?

Hello, all. I just started using the email import script (‘add messages to DevonThink’) with DTP 1.2.1 and Entourage. I’m getting what I think is strange behavior: after selecting a number of emails and running the script, they don’t show up in the open database. However, after I quit DTP then restart using the same database, the messages do appear. Only I’m not quite sure where they appear-- they are just listed in a pane at startup, and are not actually in any of my defined groups. So, I have to manually cut and paste them to the appropriate group. Two questions, then: first, why don’t they appear when I run the script (i.e. why do I have to restart DTP to see them); second, where are they when I do see them.

I should probably be able to figure this out, but I’m deep into a project with a deadline and can’t afford the time to play around with it. Thanks in advance!

Eric B.

Eric, the messages are being stored in the database. You really don’t have to restart DT Pro to find them – they are there.

You can verify that by searching for text that’s contained in a message.

If you want to see where that found email message is stored, select it and press Command-R to Reveal it’s location.

Okay- I think I just figured it out. If I select and import less than about six emails, they do show up in the open DB. If I select more, they do not. However, it turns out that I don’t actually have to quit DT, just minimize the window then open it again and they all appear. It’s still weird, and I’m still not sure where those messages are located. I look forward to the beta of the new script that allows import into a specified group. :unamused:

Thank you, Bill. Our posts crossed. Everything’s A-OK.

Well, I thought everything was OK, but I’m still having two problems. First, when I’m in a database group-- say I’m editing something-- and use the “add message to DevonThink” script, where does the email show up? It’s not in any of my groups and I can’t see it unless I do a restart. I’m sure this is just my inexperience.

Second, the timestamp on the imported message is always “1/1/04 12:00 AM” (this is not a problem when I use Apple Mail, just Entourage, so I assume there might be a bug in the Entourage version of the script?).

Thanks in advance,

As a PS- what I’m doing now is Edit–>Find–>In Database on a keyword and when the email or webpage appears I can move it to the desired group. But there must be a better way than having to remember a keyword, particularly since this approach quickly leads to a large search result.