Error Importing Email - <__NSDictionaryM 0x1f848b50>

Hello All,

I’ve tried everything I could possibly think of and I have no idea what else to do. I’m pretty Mac savvy (and work in the digital business) and I’m at my wit’s end.

I have around 13,000 emails in a gmail account that is IMAP’d to my local

I’m running version 2.4.3 of DEVONthink.

My Mac is brand new, Retina, 16GB, 2.7GHz.

I am only starting to learn to use DEVONthink but in just a short time I’ve realised it’s far smarter than I will ever be, as long as I have the RAM for it.

I am trying to import my email. All 13,000 of them.

I receive:


[<__NSDictionaryM 0x1f848b50> valueForUndefinedKey:]: this class is not key value coding-compliant for the key media only screen and (max-device-width.

Please contact with this error message and any information you can find in the Console at this moment.


error message when trying to target All Mail.

I’ve even gone so far as to try and target the problem emails. Their subjects fall within the letters D-F. Nowhere else seems to have a problem.

I want to, easily, be able to add email through the email archive/import function without just ‘dragging’ the emails in. I’d like to do this because when dragging them in they enter as individual emails instead of folders. When trying to Auto Group 13,000 emails DTOP just seems to … stop without auto-foldering them.

I beg of you, please help me. I’m starting to go bleary-eyed and scare the family.

All I can think of is some ‘invalid’ characters in the subject but I can’t seem to locate any in the 1,000+ emails that encompass subject letters D-F.

I just don’t know what else to do.

Thanks in advance.

p.s. I’ve attached a screenshot of the error for further enjoyment. I also tried a Google search and the results are too ‘developer-y’ for me to understand.

Well incase anyone is interested I managed to get the email in as wanted but it was no easy task.

I continued to test every email based on subject starting letter across 13,000 emails. Nothing mattered.

Eventually I managed to find the offending emails and moved them aside.

Then I was able to import the entire batch and have it sort to folders as DTPO does by default.

Oddly, I then imported the folder that contained the offending emails and that worked with no problem whatsoever.

I then combined everything. Seems the job is now done. Future imports will bring in only the new email and ignore previously imported so, job done.

Thanks though.

Interesting… There was no noticeable commonality in the offending emails?


Once I got the bulk of them in the remaining offending emails went in as well. It’s like that 14,001 emails were 2 emails too many.

The only change I made…

When you IMAP gmail into Mac you get the folder tree that represents the labels you have in gmail.

By default Gmail in via IMAP created a folder called [gmail] that contains the core labels. Those being: All Mail, Sent, Drafts, Trash, and a couple others.

I received the error in DTPO when trying to import from the label ‘All Mail’.

So, I created a new label called DTPO Archive and placed it outside of the “[gmail[” folder/parent label.

I then labelled ALL emails except the offending to that new label called DTPO Archive. As a child of that label I created a label called “F” for the offending emails (since they all started with the subject letter “F”).

From there I was able to import the emails as stated above. I am wondering if it was related to these ‘default’ labels from gmail. However, I had no problem importing the drafts from that folder so it seemed to only happen on the “All Mail” default label.

I truly cannot explain it but i can tell you this, I’m glad it’s done.

In the future I’ll need to update the DTPO Archive label with all the new emails and then DTPO should let me import those not already imported making my life a bit easier.

I have no real advice to offer but hopefully if anyone else comes across some funky experiences with Gmail this might help.

Oh, I should also mention that the gmail account is a work account and it is on Google Apps and not the free version of gmail. (However, I also had no problems importing my personal, non-Google apps gmail into DTPO.)