Error message when using DTP office

Screen shot 2010-11-17 at 2.03.53 PM.pngAfter installing the last two updates to Devonthink pro, I keep getting this message. It shows up when I try to use the sorter, and randomly when I open a previous item in the database. It says: Couldn’t write some or all metadata attributes. I have tried verify and repair but do not get any information back. I am not sure rebuilding the database will help, so haven’t done this yet, but the message is annoying and mysterious. Hoping someone can help guide me to the next step. I keep my main database on Dropbox and it has been working flawlessly until recently.

Cathy Scrivnor
DTP Office 2.06, OS 10.6.5

I’ve figured out it’s my Devonthink Sorter that’s causing the problem now. I’ve moved my database out of DropBox and was in the process of creating a new database when I noticed that even my new databases were exhibiting the same error. If I completely turn off the Sorter, then the error messages goes away.

How do I fix this issue, so I can again restart the Sorter. In the process of creating a smoother workflow, and want to include the Sorter into it. I am desperate to create a paperless office here.

Sounds like your installation is corrupted somehow. Try to download a fresh copy and reinstall (here’s some recent advice on that). Be sure to close Sorter first. If that isn’t solving the problem, then there may be a corrupted database. Try Verify and Repair or, if needed, Rebuild (both in the Tools menu).

Fixed the error! Thanks. I went through and thoroughly deleted my DT installation then did a fresh install. Everything is working fine now. My global inbox was the culprit.

thanks for your help,