Exclude from Tagging greyed out

Is there a reason why the checkbox to exclude an item from tagging is greyed out? I have a css file that needs to be in the root directory of an indexed location and it is littering my database with tags (I have “Convert hashtags to Tags” enabled).

Screenshot 2020-09-12 at 10.18.16

That option only applies to a selected group in a database that doesn’t already exclude all groups from tagging. It doesn’t apply to documents.