Export Files & Folders fails after restore

I had to move my DevonThink database from my backup external drive to my desktop computer after my laptop crashed.

I tried to export a subset of the database (a folder with only various rtf and txt files) to take with me to work, since I needed the info. But only 2 files were actually exported (no Devontech_storage file) and after that, the export options were all greyed out. I quitted DT, restarted and exported to a single rtfd file.

I tried exporting another folder (with less files in it) and that went ok, with a Devontech_storage file and all.

What could be the problem here?

I also noticed that on starting DT the database doesn’t automatically open, even though I specified opening th last open window before quitting in preferences.

Groet,
Adelheid

Actually the latest version should log (see Tools > Log) every item which could not be exported. Did you really use File > Export > Files & Folders? Only this command creates the storage files, the other export options don’t create them and create one large file.

In addition, all export commands require a selection. If things should still not work, I would recommend to use “Tools > Verify & Repair” to ensure that the backup from the external drive is actually fine.

This option does not open the last used database but opens for each (!) database the same windows which were open before quitting or closing the database.

To define a default database, use the “File > Database Properties” panel.

Yup. I’ll try again and check the log to see if anything goes wrong. I also tried rebuilding, but that hangs on exporting file number 19 (of 2.080).

Did that, but it showed no errors.

Thanks, I’ll do that.

Groet,
Adelheid

Unfortunately, after starting the export (I selected a folder, then Export > Files & Folders, to export to desktop) the Tools > log option is also greyed out. Every option in every menu is greyed out as a matter of fact.

I can browse other folders while this is going on though, so it is no total lockup. Can’t explain it.

Groet,
Adelheid

Actually a progress indicator should appear if the process needs some time. In addition, almost all commands are disabled while exporting. Sounds like something strange is going on… is anything logged to the system console (see /Applications/Utilities/Console.app) related to DT Pro?

I could find nothing in any log (checked al I could find). I just downloaded DevonThink Pro again and re-installed the app. Now exporting works like a charm (indeed showing a progress bar).

All is well again.

Thanks for your replies.

Groet,
Adelheid

You can check Tools > Log after the export is finished.

The Log can be saved to a location of your choice. And if you are planing to do another export, you will probably want to click on the Clear button if you want to limit the report to just the next export.