Failed iCloud Sync in DTTG

I got the DTTG app and have now tried to sync. I created, as recommended a sync password.

However, DT3 happily keeps showing me this dialog:

Also, the synced database does not show up on the iphone in DTTG. Nor does the iphone ask me for the sync password (I supposed this is expected since the database isn’t found).

The database shows as synced in DT and on the iphone iCloud.

The massive upload activity ended a while ago but no database on iphone. iCloud sync set up. Not sure how to see the “synced” database.


"massive upload activity from where?

You can’t use two different encryption key values on the devices. They must be using the same value or both left blank.

Did you set the key in DEVONthink To Go first, then attempt to sync DEVONthink?

I’m not trying to use two encryption keys. Sorry that wasn’t clear.

I first uploaded the DT database to iCloud first using an encryption key. I’m assuming the encryption key is specific to the individual database and not otherwise related to other passwords.

Then, tried to read/open the database in DTTG. I “expected” DTTG to see the database and ask me for the encryption key. Nope. Instead, I get an “invalid encryption key” on the iphone now also. There is no dialog letting me enter the one I set on the mac side.

I’m not sure how to even set the key in DTTG first, if that’s the correct way to do it.

Also, probably related, I created a “Test” database in DTTG, but the “Remote” section of Sync in DT3 is blank. Thus, no sync from DTTG to DT3 either.

I’m assuming the encryption key is specific to the individual database

It is not. It is set for the sync location.

and not otherwise related to other passwords.

Correct, as it’s not a password so you’re not going to get a dialog to enter it.

So you did enter an encryption key in DEVONthink’s Preferences > Sync when you set up the iCloud location?
If so, you must use that same key in DEVONthink To Go’s Settings > Sync: Locations. Go into that section, press the Edit link then touch the iCloud location. You need to enter the key in both fields and press Save.

Thanks. I didn’t see how to Edit the iCloud connection in DTTG, but that fixed it. The database is downloading to iPhone now. (Lots of space taken up).


No problem