Failed install and absolutely no feedback!!

Hi, just purchased DTpro & DAPro as a package.

Had trial version of each already loaded on 2008 macbookpro running lion.

after purchase downloaded updated vers. but was unable to delete older vers.

put mac into recovery mode by holding down shift key as instructed by apple and was able to remove and install DAPro with lic. details.

DTPro however refuses to delete.

Under trial went from DTPro to DTProOffice. After download of purchased DTPro update and attempt to instal system tells me that DTPro is still installed dispute attempts to clean of programs. System message on install tells me that DTPro is still installed - i cannot see any trace of trace of old program.I continue on with install of DTPro and licence message tell me that lic. number is for mac ruing DTPor Office!

Instal DTProOffice and same problems with lic, telling me now that i must use lic. on DTPro Office! DTOffice Pro not install.

have contacted help but no response.

Anyone have any suggestion in getting rid of older program to put on?

contact assistance but no response from them - for ages.

There are no unanswered Support queries of this kind. On Tuesday, March 20, 2012 a Support message of a similar nature was received and a response was sent less than 5 hours later, that should have resolved the issue. However, the original message was updated today, complaining that no response had been received.

If you have a junk mail filter installed, please check your junk mail folder. Comment: I especially hate filters such as Earthlink’s that require interpretation of the text in an image. My elderly eyes have trouble interpreting some the color graduations, but I go to the trouble of authenticating future responses from Support. However, people who use this filter should be aware that they will not receive responses from automated servers, such as our License Code emails, our newsletter and (potentially) some responses from Help > Support Assistant.

The relatively rare glitch that can be encountered when using the Update feature in DEVONthink to download and install an updated of the application can be resolved by the following procedure:

Perhaps there was a glitch during download and the application was incomplete or damaged. If so, there’s no threat to your database(s).

  1. If the Sorter is running, click on the tab to open the Sorter panel. At the bottom of the panel, click on the cogwheel symbol and choose ‘Quit’. Or open Preferences > Sorter in the DEVONthink application and click on the ‘Quit’ button.

  2. If the DEVONthink application is running, Quit it. Now Control-click (right click) on the installed application and choose the contextual menu option to move it to the Trash.

  3. Go to our Download page at devontechnologies.com/download/products.html

  4. Click on the link to download the application for which you had purchased registration, e.g., DEVONthink Pro. When the download is complete, locate the new .zip file in your Downloads folder and double-click it to unzip it. Then double-click on the resulting .dmg file to mount it as a disk image.

  5. Drag the application file from the disk image to the Applications folder. Launch the application and allow it to run the ‘Install Add-Ons’ procedure. Now you are ready to work with your databases using the new version of your DEVONthink application.

HI again,

I have logged this with support again: twice before, but i cannot see the record, only other stuff about trial serials etc. So no clue as to what happened to my other posts. Perhaps i did not send them correctly?

Back to this problem:

Tried deleting the application DT-Pro manually, by accessing the ~lib folder.

I did an extensive search for for DT-Pro files and thought I had removed them all.

However, after a fresh download and install the same message comes up when i try and confirm the serial number.

Obviously, there are a lot more files belonging to the program that i need to locate and remove. Can you please provide a list of all DevonThinkPro for lion files that I would need to remove.

Other than that, the system must be caching an install record, or record of the older programs and then rejecting the serial because it doesn’t match?

I have completely removed the database file off to another computer so that the new install thinks it needs to set up a fresh db.

Do you have wiki on how to remove the All DevonTechnologies program? Im thinking that I might just start afresh and see what happens.

Regards

It’s really not that complicated. OS X doesn’t allow one to delete a file, such as a DEVONthink application, if the file contains a process that’s still running.

If an application such as DEVONthink Pro is running, OS X will not allow the user to move it from the Application folder to the Trash. The application must first be Quit.

However, if the Sorter is running, your attempt to move the DEVONthink application to the Trash will not be allowed, because the application file contains code that’s still running – DEVONthink Sorter – even after the DEVONthink application had been Quit.

The Sorter must be Quit before the application file can be deleted. There are at least three ways to Quit the Sorter:

  1. While DEVONthink is running, Quit the Sorter by choosing that option in Preferences > Sorter.
  2. Click on the Sorter tab to open the panel, then click on the cogwheel symbol at the bottom of the panel, and choose Quit.
  3. Launch Apple’s Activity Monitor (Applications > Utilities > Activity Monitor.app), select All Processes, then select and Quit the DEVONthink Sorter process.

Now you may select the DEVONthink application file, Control-click on it and select the contextual menu option to move it to the Trash. That should be done before a different edition of DEVONthink is installed, in order to prevent confusion for scripts and Services (and the user).

Note that it’s not necessary to rummage about within the User Library to quit a running process such as the Sorter.

Once that issue has been solved, your other issue, registering the DEVONthink application edition for which you purchased registration, becomes simple.

Download and install the correct application. Enter your license code information (Name, Organization-if any, License Code) EXACTLY (no changes or typos - copy/paste works) from your license code email message into the corresponding fields of the registration panel. When the last field has been entered, the Register button will activate so that you can click on it to finish.

Note: After installing the DEVONthink application manually or by the Update assistant, run the Install Add-Ons procedure so as to update components installed in the User Library.

Bill, your explanation is a total nonsense and a complete miss reading of the problem I (now, was) experiencing.

As i said in my first post i could not get DEVONThinkPro office to delete after I purchased the serial for DEVONThinkPro. ( I had purchased the Agent + Pro bundle. NO problems with Agent, works a treat. TA!)

When I tried to enter the serial it was rejected with a program message(?) telling me that the serial was for the office version. When I downloaded that version and installed it i would then get the same message only this time it informed me that it was for the previous version. And so on it went. ( I have posted screen grabs in Support) In my mind there must be some file mis identifying each install, so ALL fils had not been removed.

On the first uninstall I did stop the Sorter and after each install to the lic. screen, I was unable to install the sorter and other menu files associated with the program. And as far as I could see, no process had restarted on each uninstall/install.

As previously mentioned, I then took it up with Apple re a problem with Lion? ( The Case is still open) Their advice was to put the mac into a basic system startup by holding down shift key, where only system processes would be running and do another uninstall/install. The idea was as per your suggestion, to stop processes that prevented uninstalls.

However the same problem occurred - the same little pesky notice again!

Their advice then, was to take it to a Genius Bar and let the boffins have a look at it. I’m three hours plus away from said Boffins. so not an option.

After a search I came across a lion problem with the "ubiquity’ folder in the ~lib/application support folder and permissions changing mysteriously.

I checked my account folder and permissions displayed a ‘fetching…’ for the main account holder. I replaced this with myself as the correct account holder and checked other folders. I also moved the ‘ubiquity’ folder to the desktop then shutdown and restarted.

The same problems occurred and I then tried deleting as many of the DT-Pro files as i could find, and then tried another install. Again the same thing with the serial rejection.

I then found the dmg of the last DTPro to work. I tried to open the program and it asked to install, which I did. Again the serial did not work so this time instead I cut and past from a PDF copy of the original serial email, and it worked!

It had nothing to do with processes still running. It looks like the original lic. mail is corrupt or the lasted version’s lic screen has a bug. I suggest you take a look.

I got the program to update itself, and so far, everything seems to be working the way it should.

I do not agree that my response was nonsense. It described the issues you experienced and the most probable course to resolving them. :slight_smile: