Failure 'printing' PDF to DT Pro 2.0 from Lotus Notes 8.5.1

I tried to ‘print’ an email form Lotus Notes 8.5.1 (FixPack 1), sending it to DevonThink Pro 2.0 as a PDF. Sending to Evernote and other apps as a PDF works just fine, but sending to DT Pro results in the following error:

DEVONthink Pro

Notes got an error: «class DTcu» doesn’t understand the exists message.

Any ideas as to what’s wrong here, please?

Please remove all scripts related to DEVONthink from ~/Library/PDF Services and install the latest ones again via Help > Install Add-ons. Does this fix it? If not, then please save this script in the above folder and try to print to it:

on open these_items
			set this_file to item 1 of these_items
			tell application id "com.devon-technologies.thinkpro2"
				if not (exists current database) then error "Please open a database before using this script!"
				import this_file
			end tell
		on error error_message number error_number
			if the error_number is not -128 then display alert "DEVONthink Pro" message error_message as warning
		end try
end open

Thanks very much, Christian - your first tip about deleting shortcuts from the PDF Services folder did the trick - FYI, I needed to log out & back in again for that to take effect (though you may have assumed I knew that!).

Thanks for the prompt response with an effective answer.


For me it does not work. I deleted the “Save PDF in DEVONthink Pro.scpt” in ~/Library/PDF Services and installed it again. Then I logged out and in again, started Notes and DEVONthink Pro Office. The same error message (in German) appears. Then I copied the given script under a new name into ~/Library/PDF Services. The same error message also with that.
I am using a German language version of DTPO. Might that be the cause?