feed updates not downloaded? [solved]


This is my 1st post on this forum, I am new to DTP (3 months) but I already love it: thanks for this great software.

I am having trouble with several feeds, for instance:

These feeds are regularly updated: using curl, I can see the 10 lastest entries including the new ones which do not appear in my DTP feed. If I delete the feed in DTP and setup a new one, then I get the 10 lastest entries, but of course I loose older entries, which I do not want. I have setup DTP for daily updates on my feeds.

Nothing is reported in the logs, the activity window shows some activity if I click “Refresh Feed”.

Could you give me some guidance please?


Which settings do you use in Preferences > RSS? By locking the feed you can ensure that no entries from the feed are automatically removed. In addition, does updating the feed manually afterwards (see contextual menu) add the missing items?


thanks for answering. Sorry if I was not clear. Some feeds behave correctly, for instance with code.fb.com/category/ai-research/feed, DTP retrieves the new entries and keep the older ones, as expected. I never needed to lock the feed to get normal behavior. However, for the 2 feeds I gave previously as an example, I have a problem because DTP does not retrieve the new entries, even if I manually refresh the feed via the “Refresh Feed” menu option (and again reading the xml feed via cURL confirms that those new entries are present).

For those problematic feeds, the only way I could find to get the new entries is to create a new feed in replacement of the current one. I did this several times and it made DTP retrieve the new entries. This of course has the drawback of not retrieving the entries 11+ because those feeds yield the 10 most recent entries.

Here are my RSS settings, nothing fancy I guess.

Thanks for your support!

Does it work as expected after disabling the “Skip duplicates” option?

No, sorry (I also tried this after restarting DTP).


Additional info: these feeds are in a database which is synced:

  • via iCloud with DTTG (I know DTTG does not update feeds)
  • via webdav with another instance of DTP (my mac@work). This instance is configured with the same RSS settings, I have just checked that again.

As I’m digging this issue, I’m thinking it may be the case that the new entries appeared on the DTP on my mac@work while I was at the office, and there is a glitch at this point. Anyway, I have just checked that the new entries are not present on DTP on my mac@work.

It’s just a clue, I have no idea what it’s worth.

PS : I have 2.10.2 on both macs. One is running Mojave, the other High Sierra 10.13.6.

I’d suggest to toggle the locking of the feeds and to refresh them manually afterwards, this should definitely add all available items not yet stored in the database.

It worked! great
Do you suggest this as a one-shot workaround or should I do this regularly?


This should definitely not be necessary regularly.

Ok, I see. Perfect