Feedback: Sync2 works very well now (UPDATE)

This is an update. I post this as it might be helpful for others, and to adjust the record. I was highly critical at a time, when from all I can tell, that was fully justified. But now, I should be equally vocal about things working very well.

My original post dated August 19, 2016, came to the conclusion that Sync2, at that point was not workable for me. The situation has dramatically changed. It should be noted, however, that nothing on my end had to be changed, there was no wrong setup, no “bad network” or whatever.

Things turned around due to 2 factors:

  1. For the internet-based syncing I had chosen Box. Turns out that at least for my Box account, after some minutes to hours of proper operation, syncing would get stuck on Box, and could only be restarted by logging in and out of their web interface on the Mac. Then the cycle would repeat. Especially bad was the fact that this would also hold up local Bonjour syncs. After I became aware of this, I tried Cloudme and things have been absolutely smooth.

  2. A combination of the 2.0.2. and 2.0.3. updates had a dramatic influence on my syncing, internet and Bonjour-based. While Bluefrog stated at the time of my original post that for most users sync was working perfectly well, the release notes indicate that numerous things got fixed and critically improved.

At the time, my several databases with around 1000 items each, would very frequently start re-syncing essentially all items, even on days when these DBs were not touched at all. The speed of the sync was roughly compatible with all data in the DB being pushed across the network.

This is now all a thing of the past. I have one Mac, an iPad, and an iPhone. I have Bonjour sync set up between them to do heavy lifting (initial sync, updates after adding big or many files), and also internet syncing via Cloudme (“on demand” setting on iOS devices) so each device can access everything even if the other two are not active on the same network.

I just spent a week at a conference where my only internet connection was via the cellphone hotspot on my iphone. DT/DTTG syncing through Cloudme worked very well. Since there was no re-syncing as I experienced pre-2.0.2/3, the data usage was very close to the combined size of files I added or modified. This demonstrated that DT syncing with nothing but a cell connection is now entirely feasible (assuming “reasonable” files and file numbers).

While we can expect more improvements in the future, from my end it is fair to say that with DTTG 2.0.3, DTTG2 has truly arrived in the form that I and many others had hoped.

DTTG2 functionality (other than syncing) has been fantastic from the start. Now it is an overall great package. There is nothing like it on iOS that I’m aware of.

I have collected a good number of suggestions for improvements that I will bring up in separate posts.


Original post, August 19, 2016:

I was extremely excited to switch to DTTG 2, and I generally really like its features other than sync (even though the pre-defined “smartgroups” should really not be called smartgroups, that’s overselling it). The app is swift, and pdf editing is fantastic (caveat: on the 12" Pro, the pencil tool is too lagging to be used with the Apple Pencil for handwriting margin notes; I have not encountered any other doodling/annotating app that is laggy, so my preliminary conclusion is that the DTTG pencil writing code is not efficient enough for this purpose).

But the sync has been (on my system!) a big disappointment so far. I’ve been at it for 5 days now, and at this point, syncing between my Mac, iPhone, and iPad is not working in a way that would make the DT ecosystem useful in a meaningful way.

I have been a staunch supporter/defender of DTTG1 and its syncing in the past! I have always synced all my DBs onto DTTG1 (around 5 GB), and after some initial issues a few years ago, the sync has worked very well for me.

Sync2 has been a mess in my case, and I cannot pinpoint anything concrete. Rather things fail in arbitrary ways.

The following is sadly a fairly unfiltered and raw dump of what comes to my mind right now. Apologies for that. But I think this reflects that fact that the things that trip me up are so random.

Since I have 5 GB of data to sync in around 5 databases (total of a few thousand files, less than 5k), I first tried to sync by wifi method only (something that with exactly the same DBs had worked perfectly on DTTG1). Seemed to go OK between Mac and iPad. Later, did not really work well on iPhone. With a lot of fiddling, restarting, this and that, finally got it synced.

Naively thought that once the first “mega sync” is done, things would go alright with a much lighter syncing load. But then I noted that:

  1. DBs that I had not touched explicitly on ANY of my devices suddenly got fully re-synced (in up and down direction).

  2. Update syncs would often get stuck, or take an extremely long time, even when there is nothing new to sync!

We are always warned of “bad networks and routers”. Well, this behaviour is not changing between home and work, and a research facility I just travelled to. So far I’ve used the local sync on 5 different wifi setups, all different brand routers, and all of them have done their non-DT duties faithfully for years! None of them has given me outside of DT any indication of any “network problems”.

After disappointing results with wifi-sync, I set up a account and synced the Mac to that. Once finished, created a sync to that store from the iPhone. At that point, I had brought the iphone (after quite a bit of prodding) completely in sync with the Mac via wifi. And since the Mac was 100% in sync with Box, I figured that the iPhone-Box sync could go down without exchanging all the files explicitly. Yet, from the speed of the sync and the information that the DTTG gives (“uploading 1035 files to box…”), it seems that everything is transferred from scratch again. Worse, once that upload finished, shortly after a download from box commences, again claiming a download of 1035 files, and the speed of the process suggesting that all file content is transmitted.

Similar struggles on the iPad.

But worse: After a load of waiting, trying and re-trying, things seems to have synced OK, subsequent sync get constantly stuck, and then suddenly 1000s of files are transferred again, when in between all I have done is create one more “hello world” plain text file to check how reliably and quickly such a file gets synced across my system.

Since DTTG can’t sync in the background, I always have to keep the iOS devices running with DTTG in the foreground to try to make it through those long sessions. This has killed my ability to actually get work done.

Even on the Mac end, the Box sync sometimes seems to get stuck in endless spinning wheel session, often only for one DB, that was not even touched in the meantime. It should instantaneously update, since the sync should trivially determine that neither on the Box side nor on the Mac this DB has been touched! Maybe the connection to Box is flakey? I have no experience with Box, opened a new account just for DTTG2. But my Dropbox and Omnifocus connections never, ever fail me.

Today, I had enough. Removed DTTG2 from my iPhone. Reinstalled from scratch. Then, sitting on an excellent high-speed internet connection, tried a fresh sync from the Box store. 15 GB free in iPhone, DBs around 5 GB, but only trying to sync one of them, size around 1GB. Surprise: Now DTTG2 crashes halfway through the sync, no matter what.

Next move: Toss the Box sync from the iPhone, and set up a Wifi sync between Mac and iPhone, using a router that has always worked with DTTG1 and whatever else I threw at it. Only chose the global inbox for syncing, leave the others unchecked, so less than 1 GB. That local sync has been underway now for almost an hour. So it seems to be on the same router way, way, slower than the “slow” DTTG1 sync.

Sorry to say, there is something fundamentally wrong here. It is entirely possible that there is something on my end that I have not set up right. But as others have pointed out, syncs need to “just work”, otherwise there is no point. Dropbox and Omnifocus and some other things do this transparently and flawlessly on my system. Apple Photos/iCloud is already not that hot in that respect, and DTTG2 sync is not working at all for me right now.

It is OK to have to struggle with the initial syncing, but subsequent re-syncs have to be swift and reliable. If a system is fully synced, and after only changing or adding a handful of trivial files (plain text “hello world” type files), the sync gets stuck in mysterious ways, this is not workable.

It’s odd, but at this point I wish I had DTTG1 syncing back. Do I need to wait for 2.0.2?

Posting a fake reply to push my above update to the top of the list :smiling_imp: