File not yet available without indexed files

Hello everyone,

we already had this conversion a couple of times here in the forum, but it always hinted into the direction of indexed files.

I now have some (about 610 to be specific) files that are “not yet available” in my database, that were imported, but not indexed files. When I hit the download-button, nothing happens. In the log window it says “file still pending”.
Can anyone help me out here what the problem might be and how to fix this? How can I get those files back into my database and working as they should?

I am working on a MacBookPro 10.14.6 with DT 3.8 and sync via WebDAV-sync stores to my ipad mini 6(15.1) and iPhone (15.1)

All the best and many thanks.

Which device were the files imported on, and on which device are you seeing the files not yet available message?

The message would be suggestive of the files having been imported on one device and not having been completely synced to the device on which you are seeing the error. That could be suggestive of a more general syncing error, and it would be worth checking to see when you last successfully synced all devices.

Hey @Blanc

since those are many different files, I believe those were imported from different devices, mainly MacMini and iPhone, but mostly from my MacMini.

I have checked all instances of DT and DTGG, everywhere I am not able to download those files. I believe those files have been available approx. a week ago, so there must have been some issue within the last couple of days.

I had some “missing .manifest” issues the last couple of days in this database. What I did (after reading through this forum) was to clean the sync stores and synced the data back into the stores from one device, my macMini, which is my main instance of DT running.

As Jim will ask, is anything reported in the log? It seems fair to assume that the devices are not currently in sync, and the files in question are not available in the sync store. Actively try to sync each device with the sync store, checking to see whether a sync actually takes place and no error is shown. Obviously changes will not be reflected on each other device until a second sync is performed.

I’m puzzled. I don’t think DEVONthink on Mac offers to “download” files already imported. Sure not indexed? I suspect you have incomplete sync. I suggest on your Mac Use DEVONthink to see when last synced, and verify the database(s) in the WebDAV Sync Location. Menu: Preferences, Tab: Sync.

1 Like

You can see this behaviour if you, for example, import a file into DTTG, and an incomplete sync with the Mac takes place. That sometimes happens to me when DTTG seems to initiate a sync of its own accord when not apparently active. The file then shows up in DT, is marked as pending and offers a download button. The download button cannot work, because the file is not yet available in the sync store (or in my case: there is no sync store because I am using Bonjour). The record becomes available in DT as soon as I perform a successful sync from DTTG.

If I am correct, then it is necessary to check when the last sync occurred on each individual device.

1 Like

I think we are in agreement here… I can see how this happens on DEVONthink ToGO but OP said “DT” shows this behavior. Not yet to the bottom of the issue, though.

Well,

I stopped all syncs on my devices (MacMini, MacBookPro with DT) and iPhone with DTTG. I have checked the database and verified them. Nothing odd. The log already told about the files “still pending”, after I tried to move them to a different location.

I believe the sync has already gone through all devices, since I have the same “pending” status on all devices, I cannot access those files from anywhere. It seems as they are completly gone.

I have never worked with indexed files and folders yet, I am always importing. I have never seen the “indexed icon” in my database yet. So I think those issues have nothing to do with the indexed status.

Any more ideas to help me here?

So did I :wink: but only in conjunction with a second device - that is the condicio sine qua non.

I am going to wait for Jim to confirm, but I suspect that the original upload to the sync store never worked, and the files were therefore never made available to the other devices. What I cannot explain is why the file has become unavailable on the respective original device. There was never a further device involved which is no longer in your possession presumably?

An idea: if the original upload hadn’t worked, and you moved the file to a different group on the original device, sync no longer worked, you erase the sync store and then initiated a new sync, then the incomplete record would have synced back to the original device, unaware that the original file was actually available on the device (I think that explanation is probably too simplistic, because, in theory at least, the record ID should remain). It might be worth checking to see whether the pending files are actually incomplete duplicates of existing records.

Good to verify the databases. Also verify the sync locations (if not done already) as suggested above. Symptoms, as @blanc mentions, support an incomplete or perhaps corrupted sync locations.

Even here, sync stores are successfully verified on MacMini and MacBookPro. No issues now.

OK, but to clarify the sync store are not on those devices. They are on your WebDav server).

I’m out of ideas (but what I’d probably do is simply clean the sync store for the malfunctioning database and start fresh. Up to you of course.)

Yes, the sync stores are on my synology nas and are accessed via WebDAV, correct.
What would happen if I clean the sync store completly and sync the data back? Since the files are not available in the database, they would not sync into the sync store, right? So this would not lead to any improvements, I believe?

See my response above. If you can identify at least one Record and its original device (a Mac), you could try selecting “Show in Finder” from the context menu. This shouldn’t identify a file, but it’s worth trying.

Well, I just spotlighted some random files and found them as devonthink documents in the finder. I could go through all 680 files and try to find them locally, and re-import those into my database. But then I do not have the pdf-file but the devonthink document file in my database, including the devonthink-internal name of the file (e.g. 6F960646-DFC6-40A3-BA29-2F621DFF4E3A)

“Show in Finder” was on the original device, the MacMini, not available within the context menu.

Importing those files will not be helpful. Can you remember from where you imported the files to DEVONthink originally? Was it from an online drive or any other not directly locally attached drive?

Hard to Say, since there are some older files included, that were probably been imported on my older macbookPro, I do not have anymore. Some files were probably been imported from dropbox or synology-drive-cloud services.

What would be the advantage to know where those files were from?

Side-Note: I have restored an older version of my database from 2 weeks ago and opened it. Those files were included and could be transfered into my current database.

Is this useful or does this maybe mess something up?
And has someone an idea of how to easily find those files that were pending in the backuped database with a rule or something? Or do I have to manually go through all 680 files and located them?

A toolbar search for item:pending should be sufficient.