Files Disappear!

Something bizarre just happened with DEVONthink and I apologize for the length, but it’s going to take some writing to explain.

I just recently purchased it and started using it and began creating some groups and dragging files (pdf’s, rtf’s, URL’s) and capturing text into them. Everything worked great. I then discovered that DEVONthink can index files. So, knowing I had a folder called PDF Files in my Documents folder (containing about 300 pdf files), I decided to try it out last night. It looked like it worked, except for reporting an error on about 5 of those 300 files. From looking at the titles of the files, and knowing their contents, I was not concerned. I then looked at what DEVONthink had created. I saw a “group” called “PDF Files” in the left-hand list of groups, and I checked out the contents. Looked excellent! All my PDF files were there (except for those noted in the log), and they previewed (full resolution), and searched correctly. Awesome.

So, today, I launched DEVONthink and decided to take a closer look at all those PDF files and perhaps do some purging of unwanted documents. After looking through the list in DEVONthink, I saw a few files I no longer needed. I went to the Finder to the original PDF Files directory, and dragged those files to the trash. Nothing unusual happened. Everything looked normal. Except when I went back to DEVONthink, I noticed that the folder icon for the group “PDF Files” had turned into a gray square with a dash in it. Strange… I also noticed that it still acted like a folder… i.e., I could select it and view the contents as before, and I could see the thumbnails of all the pdf files as before. OK, I thought, no obvious problems. I then went back to the Finder and to my shock and surprise, noticed that there no longer was a “PDF Files” directory! Completely gone… I did some Spotlight searches and came up empty. Yes, they were really gone. No where to be found. I checked the “PDF Files” group again, and this time looked at the pdf files more closely. Turns out they were all just the thumbnails. No actual documents existed anymore.

And that’s my story… I indexed a directory in the Finder, trashed a few files, and everything disappeared. I tried to use the options under the “Tools” menu (Verify and Repair, Backup and Optimize) to no avail. I really didn’t think they would be much help at this point. I don’t consider this a life or death situation, since I can regenerate or reacquire most of those pdf files, but I think you can see that this is extremely disappointing. The results were completely unexpected. So although I would appreciate being able to resurrect these deleted pdf files, I would also appreciate knowing just how a situation like this can be avoided in the future, or if there is a deeper problem in the software itself. Besides this one unfortunate event occuring so early in my use of the software for the first time, I think it’s a great product and, for my purposes, extremely useful. But at this point there is a cloud hanging over my head (and the software) causing me to hesitate using it for indexing of folders on my hard disk.

Solutions? Opinions? Ideas? Something I did wrong? Anything? Any help with this issue would be greatly appreciated. In the meantime I’m going to try running some data recovery software to see if I have any success recovering those lost pdf files…

Thanks for your help.

Probably a dumb question, but have you synchronized the group (cmd-opt-s)?

Hmmm… I don’t think I’ve delved into the software deep enough to know what that is yet. So, I guess my answer would be “no”. The extent of my usage up to this point has been to create some groups, put some stuff in them, and index my “PDF Files” folder. That’s about it. Is this “synchronize” option a good thing to do, or a bad thing at this point?

atreyu, from your description it would seem that you actually deleted the complete “PDF File” folder in the Finder, rather than just some of its contents. (That wasn’t done by DEVOnthink.)

Have you looked in the Trash? If you didn’t empty the Trash, perhaps the folder is still there and can be dragged back to its original location.

When you Index capture files that are located in the Finder, DT captures, if possible, their text content and metadata, including the Path back to the Finder location of each file.

But if those files are then deleted in the Finder, DT can no longer find them to display them. In the case of PDFs, you will only be able to see an icon of the first page, and the document is no longer available for viewing.

If you have Index-captured a Finder folder into DT, a corresponding group is created in your database. If you select that group and then press File > Synchronize, your database will be updated to display any changes or additions made in the Finder folder. That’s of no help, however, if the Finder folder has been removed.

If you wish to delete files that you have captured into your database, it’s best to do that from the database itself. Select one or more files and select Data > Delete. You will be asked whether you wish to delete just the content in the database, or also the ‘original’ files in the Finder.

Thanks for the tips. I have no idea how I might have deleted the entire PDF folder, since I had only selected the files I wanted to delete, but I guess it’s possible (I know it certainly looks that way, although my brain refuses to believe I would do something like that). I’ll do some testing myself to see if I can reproduce this effect or not. In the meantime, I won’t be deleting any files in the Finder, but rather, from within DEVONthink. Thanks for your help.

I forgot to add that I did indeed check the Trash… That was my first destination once I had determined that they were indeed no longer on disk. And that’s why this problem still has a mysterious “edge” to it. There were a few files in there from earlier in the day, that I had put there myself, but no PDF Files folder to be found. And I did not empty the trash prior to looking in there, to the best of my knowledge. I will tread carefully from now on…

I’ve learned from bitter experience that there’s no end to the kinds of mistakes that can be made when I allow my attention to wander. :slight_smile:

As have I… I’m running File Salvage right now to see if it can recover some of those files. No real harm done. You win some, you lose some… :slight_smile:

Further to previous problem: I was able to recover about half of the PDF files that were deleted, thanks to File Salvage. So, I decided to try this all again. I made a new PDF Files folder in the Finder and put all my recovered files in it (as well as keeping an additional copy of all the files in case of problems). Launched DEVONthink and told it to index this folder. All good. BUT… I’m curious as to what the small blue circular icon with a white symbol indicates, next to the my PDF Files group… I can’t seem to find any information about this. It must mean something, right? Anyone? Thanks again.

The ‘lightning’ symbol indicates that a file or group was Index-captured and that it is synchronized (one-way) from the external file in the Finder to the database content.