files move when tagged in version 2.6

Before the latest version 2.6, I could tag a file in a group and a replicant would be created in the new tag (where my tags are all groups). Now, the file is removed from its current group and placed only in the new tag group (as if I dragged and dropped it instead). This is not what I want. Is there a way to go back to the old behavior? If I put multiple tags on a single file, I want a replicant in each location.


I haven’t seen that behavior here myself. How are you tagging the documents? Does it happen with all file types?

I can’t replicate this (though some may find it confusing that a Replicant in a Tag Group is not colored, while they are outside the Tag Groups.

It happened several times for regular pdf files, but now that problem has gone away (for files, it is behaving normally again). However, I am still getting the problem when I add a tag to a group itself, which I have frequently done in the past. If a tag a group (in the info view), it used to replicate in the new group and stay in its current group. Now it moves entirely to the new group and disappears. I am using OSX 10.8.4 on retina display macbook.

Let me know if you still cannot replicate it.
Thanks and Best.

This is what I’m seeing here: Adding a Tag a Group in the Info pane creates an uncolored Replicant in the Tag Group but does not move the Group from its initial location.

@samrose: If you have unchecked the option to exclude ‘normal’ groups from tagging, dragging a document from one ‘normal’ group to another ‘normal’ group will move the document—as should be expected.

After restarting devonthink, I am again seeing this behavior for regular rtf and pdf files in addition to groups.

@bluefrog: now, for files in a group, I add a tag to file and hit return, and the file disappears from the current group into the new tag (note that I have to hit return or focus on a new file before the file moves). This is not what I usually experience - usually I get the same behavior you described for both groups and files.

@Bill: I am not dragging the file here. I only add a tag without dragging. I used to do this all the time and the file would be replicated in the new group but not moved, so I am fairly confident that this is anomalous behavior.

What are my options if I see this behavior but it can’t be replicated? I’m not sure how to show it to you best.

It may be relevant that I have been having other issues with DT since the latest release. It has crashed several times on Rebuild Database and can no longer Repair successfully during Verify and Repair. I don’t recall problems before the latest release. OS 10.8.4 on a retina display macbook.


  1. Have you rebooted your machine?
  2. Are you Control-clicking the files? If so, what view are you in (Three pane, Split, etc)?

I have noticed that this is happening for some rtf files now but not others. I really can’t tell the difference or find why - just that they are in different groups (both acting as tags). I’m not sure how to ask for help for such a strange and unpredictable problem. I would like to try rebuilding the database, but it keeps crashing. Any suggestions?

@bluefrog: I have rebooted my machine (before reboot I was seeing this for groups but not files - or rather not all files. After reboot - I was seeing for some files and groups).

I am in three pane view. I am not control clicking the files. It happens when I add tags to the file using the lower tag bar (which I control-return to get to) and then return or change focus (the file moves).

If it is relevant, I previously also had a problem that when I would exclude a tag from tagging (or vice versa), the group itself would disappear (moving to somewhere). I worked out that this was a bug with TechSupport and I haven’t seen the problem so far since the latest release.


Make sure to send us the crash reports (in our Support system, not here). Thanks.

Have you tried a rebuild after rebooting?

@Bluefrog - I have tried to rebuild after rebooting, but it still crashes on rebuild. I’ve saved the crash reports by copying and pasting them into word (these are the ones that my mac asks if I want to send them to apple - is this what you mean?)

I think I may have figured out some of the strange tag disappearance behavior though. It happens (at least some of the time) when I have tagged a file and then replicated the file also to a parent tag using cmd-opt-drag. I do this frequently as a way to keep my frequently used files accessible in a parent folder and also available for specific circumstances in a child folder (I know it isn’t recommended, but I haven’t found a “recommended” way that works as well - a tag of “frequently used” or similar won’t give it the context of one parent over another, and I have too many folder to make a smart group for every parent - but that is another issue - this has been fine in the past).

I think that when I add a new tag to a file that is replicated in both a parent and a child that the replicant is removed from the parent, rather than just added to the new tag as a replicant. This may not cover all of the cases, but it does happen in these cases. I don’t recall it happening before 2.6. Do you have any suggestions?

Thank you!