Files seem to be stuck in the sorter

I’ve updated to Devonthink 3. In the sorter the files I dragged there don’t seem to appear in the database. There are numbers on the basket icons. Do these mean files waiting to be imported? If so, where are they stranded? How can I get them in? I did a very big import so it’s a problem if I can’t find them.
I’d be grateful for advice!

You are likely using the Sorter for DEVONthink 2. That will not work in DEVONthink 3.

Do you have DEVONthink 2 still installed?

Yes, I do have Devonthink 2 still installed.

  1. Quit DEVONthink 3.
  2. Open DEVONthink 2 and let the Sorter to do the importing.
  3. Select Tools > Hide Sorter.
  4. Quit DEVONthink 2, then delete it from your /Applications folder and reboot the machine.
  5. Open DEVONthink 3, which uses the same databases DEVONthink 2 did, and the files should be there.

Thanks very much; I’ll do it now.

You’re welcome.
Let me know how it goes. :slight_smile:

Unfortunately this didn’t work. I couldn’t hide the sorter—it was greyed out. (Maybe because I didn’t close it first). So I quit it and tried to open Devonthink 2 again but then it asked me for my license, etc. I got it to open but most of the menu items were greyed out. I then quit and deleted from Applications, rebooted, then opened Devonthink 3. The files weren’t there.
Still, I’m a belt and braces sort of person, so I still have what I think are the files I had imported. Unless you have an idea where to look for them, I’ll call it a day.

You could “call it a day” or start a support ticket and we can handle it privately. :slight_smile:

The first phase of your instructions worked. They did import to Devonthink 2. But as I’m pretty sure I have all the files, let’s spend the time on something more valuable! It was just bad luck I happened to import 800 files just after the update and didn’t realise that the numbers in the Sorter meant files hadn’t made it to the database itself.
It would have been good if Devonthink 3 had checked to see if the old sorter was running and flagged the problem.
Thanks for your speedy help anyway :slightly_smiling_face:

You’re welcome :smile: