Find Function

I hope there are plans to bring DEVONthink’s Find function into the 21st century. Today I tried to find Gretchen’s birthday and wedding anniversary dates. I was shocked to see a search on “Gretchen” yield nothing at all, because I was sure I had entered the data.

Turns out that a search on “Gretchen” or “Gretch” or “Gr” or “Gretchen Bitrhday” wouldn’t do it because it was stored under “Gretchen’s Birthday.” Yup, the search engine couldn’t find “Gretchen” because I hadn’t fooled around with adding wild cards. It choked on the apostrophe and “s.”  

It has been years since I’ve seen a search engine with such severe limitations. In many cases it makes the Find function nearly useless, because even if I got a couple of hits on “Gretchen,” which I didn’t, I would not be assured that I’ve found all, or even half, of the information about her. Surely I should be able to type in “Gretch” and find every word containing it in my data base without having to resort to wild cards.

Please tell me that there  is a preference that will fix this!

Tom Kirshbaum

What kind of search did you do? Fuzzy, exact, no case?


did the content really contain the word Gretchen? Because I’ve just created a document containing “Gretchen’s birthday” and searching for Gretchen did of course find the document (using Exact, No Case or Fuzzy options).

In addition, it’s possible to search for substrings using the “Phrase” option and actually the only limitations at the moment are that it’s not yet possible to use complex operators like in DEVONagent or to search in multiple attributes at the same time. But these things will be enhanced in v1.9.

Ah. Thank You.

I was misconstruing  “content,” “name,” and “phrase.”  Especially I didn’t understand that “phrase” meant “string.” Now that I have that straightened out, all is well. Thanks for the quick turnaround.


Wow, I didn’t realize that “phrase” meant arbitrary substring either.  I assumed that it used word boundaries like the word oriented queries.
I wonder if this confusion is common?

Wow, I never realized how Find Phrase worked either. That’s sure easier than using Find Wildcards to match “string”. :slight_smile:

I’ve noticed Find option selection from the toolbar suffers similar drawbacks as with iTunes.  The dropdown menu can’t (AFAIK) be keyboard navigated and there’s no way of knowing the current “mode” without checking the menu. The latter might be improved with an extended tooltip, something like “Find - Content/All Words” or “Find - Name/Phrase (Global)”.

The "Phrase" option is faster than using wildcards and almost as fast as the Any Word/All Words options if the term contains only one string (and not multiple words/strings and no word separators etc.).

In addition, maybe the current mode of the toolbar search will be displayed below the field (instead of "Search").