firefox bookmarks do not appear

When I set the Bookmarks preferences to ‘Firefox’, the bookmarks drawer remains empty, though I have
a fairly extensive collection of bookmarks in Firefox. Changing the preferences to ‘Safari’ correctly shows
the Safari bookmarks. This happens with both the beta and the latest production release.

Do the Firefox bookmarks have to be copied somewhere special? It looks like Firefox uses the typical Mozila profile, which has a random user ID.

My guess is that you have modified the default layout/organization of Firefox bookmarks, and that’s why they didn’t import.

That’s been reported by other users, and you might search the forum for workarounds they have used or suggested.

That is correct, I delete all of the bookmark folders that Firefox provides by default.

Hmm, didn’t get any search results on this originally, but generalized the terms and found one
post recommending importing them via camino or safari. I’ll give that a shot.


Do you know where the bookmarks file (Bookmarks.html) is actually located on your machine? DEVONagent uses only the default locations.

It’s in the Firefox preferences directory, which has the same structure across OS X/UNIX/Windows:

Library/Application Support/Firefox/Profiles/rg4zqe9q.default/bookmarks.html

The ‘rg4zqe9q.default’ ID is autogenerated by Firefox and is stored as Profile0 in
Library/Application Support/Firefox/profiles.ini . Hmm, just noticed that firefox keeps a

Just tried the Camino import workaround. I imported into Camino, deleted the contents
of the existing Bookmarks Menu container, moved the imported bookmarks into
Bookmarks Menu. Changed the preferences of Devon Agent to use Camino, even tried
restarting agent. The bookmarks do not appear. Tried on a different user account, with only
the default bookmarks in Firefox and Camino, and neither Firefox nor Camino
bookmarks imported. Safari imports great though.

Actually DEVONagent should use the bookmarks of all profiles stored in ~/Library/Application Support/Firefox/Profiles (only the Application Support of your home directory, not the system-wide).

But I guess the problem is related to your bookmarks as the Camino workaround does not work. What does your bookmarks file contain, e.g. “scriptlets”? Has been anything logged to the system console (see /Applications/Utilities/ Or could you send me the bookmarks file to check it over here?

Just checked here at work and the firefox bookmarks import fine.

I downloaded the bookmarks from my home machine and checked 'em out in vi. I
think I found the problem:

    {DT}{A HREF="" ADD_DATE="1138871384" LAST_VISIT="1138932796" ICON="data:image/x-icon;base64,AAABAAQAEBAAAAAA

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA" LAST_CHARSET=“ISO-8859-1” ID=“rdf:#$q+6Lh2”}Mike’s Mac OS X Management Software and Tips: Terminal Commands for Lab Managers{/A}

(pretend the {} are < >)

The ICON tag is huge, roughly 10,500 characters, obviously an embedded image. I’ d imagine it causes problems for your parser :slight_smile:

I can delete them from my existing bookmarks file when I get home. This is probably a low-prioriity fix, though it seems to happen on a lot of sites (MaOSXHints, the apple discussion forums, even some sourceforge forums). Maybe there is a Firefox prefs.js setting to disable it.

If you like I can send the boookmarks.

Forget my previous post; it didn’t fix the problem.

I deleted all of my Firefox bookmarks [well, after a backup of course] and created a bookmarks file with a single bookmark for Google,
restarted both Firefox and Agent. Nothing.

After poking about a bit, I recalled some problems I had getting gfx programs working, where the case-sensitivity of the filesystem caused problems.

I copied my profile onto a case-insensitive filesystem [my boot drive and home dir is case-sensitive since I do a lot of UNIX stuff], renamed the original dir, symlinked, and restarted devon agent … worked like a charm. So the problem is that I have my Firefox [and Camino] profiles stored on a case-sensitive file system.


Seems to be a minor issue, the final release will support Firefox bookmarks stored on case-sensitive filesystems too. Could you confirm that the name of the bookmarks file is always “bookmarks.html” (and not “Bookmarks.html”) on case-sensitive filesystems? Thanks!

That’s correct, it’s all lowercase.

I just wanted to say that I upgraded to 2.0, and the Firefox bookmarks on my case-sensitive drive work fine.

Thanks guys!