FIXED! Files no longer being synced into correct groups

Devonthink Pro Office v2.5
DTTG (latest update) on iPad 2

After syncing, all files are synced across - but all displayed at the first level, and not in their correct group and sub-group file structure.

The synced groups and sub-group structure are shown, but are empty, with no files in the folders.

It used to sync perfectly, and nothing in the database layout/structure has been changed.

I have deleted DTTG app, shut down & rebooted iPad, reinstalled and resynced etc - but still the same.

Any ideas what else to try?

I’m having the same issue. It appears to happen only if the files are replicants. All of my files are direct replicants. I don’t know if it would be an issue if the group is a replicant but the files are not. Anyway, when I created a new text file directly in one of the folders under the sync folder, it synced properly.

I haven’t tried it yet, but I imagine the only way to “fix” this is to use iTunes to install an old version of DTTG.

It’s all screwed-up for me also, and no amount of resetting or rebooting has fixed anything. Also, I’m seeing all the tags in my Global Inbox synced as groups in DTTG-never saw that before either.

DTPO 2.5.1 and DTTG app store version as of 20130311.

Here’s an example of what’s going wrong:

Database structure within DEVONthink Pro Office – this is the hierarchy of the groups that are replicated to that database’s Mobile Sync group:


This is what DEVONthink to Go does with those groups – the group structure shown at the top level for that database (DTTG sort set to “Kind”)


This makes no sense. There is no logic to why DTTG is rearranging the groups, making children into parents and parents into children. Why would DTTG take a great grandchild in the Mobile Sync group and move it up to a top level group?

Deleting the database from DTTG and resynchronizing changes nothing. Deleting DTTG and resynchronizing changes nothing. (And, bizarrely, DTTG grays out the database name on the front screen as if nothing from the database was on the device.) I arrange my databases to accommodate my projects and tasks; I don’t want DTTG to munge that all together in its own whimsical arrangements :frowning:

Maybe it helps also, if those who are affected mention their devices, because in my case (iPhone 4s with the same software on OS10.8.2) the sync results are correct. Up to 6 subfolder levels deep, nothing is mixed up.
The contents of my “mobile sync” groups are direct replicants of original groups.

(Addendum: iOS 6.1.2)

iPad, iOS 6.1.2

Nice, for you. :wink:

Over here all items in Mobile Sync were replicated there.

Ditto. To prevent any misunderstanding maybe due to how I worded it before: On my groups in the database I always choose “replicate to > mobile sync” to put them there.

In the most recent version I tried to fix a problem with synchronization and added another: e.g. group serving as tags were added to the root of the database accidentally. Version 1.3.0, which fixes this issue, is already in Apple’s hands for the review.

Please apologize this mistake.

… and what about the weird behavior with group synchronization?

All fixed now!

Thank you! :smiley: :smiley: :smiley:

Yes, but … over here, to make the update work correctly I had to delete DTTG from the iPad, hard reboot the iPad, then reinstall DTTG 1.3 (today’s App Store version) and then sync. After all that, the group structure is displayed correctly.

(OS X 10.8.3, DTPO 2.5.1, DTTG 1.3.0, iOS 6.1.2)