format bug?

I was writing an article in DN (using a rich text note) and needed to italicize a word. But every time I tried to italicize the selected word, whether using keyboard or menu commands, the whole document was italicized. Same thing happened when I tried boldfacing a selected word. Anyone else encounter this annoyance or know how to get around it?


What font are you using?

Does the same thing happen if you switch to a different font?

Bill: I was using Arial. I just tried a dozen other fonts, and the same thing happened with all of them – except for Geneva and (I think it was) Georgia. I couldn’t italicize anything at all with them, not even the selected word.


That’s certainly not normal font behavior. Looks like font problems rather than a DT problem.

Do similar problems show up in TextEdit?

Can anyone suggest a utility (freeware or demo) to check the possibilty of corrupted fonts in a situation like this?

Nope. Nor any other word processing app I use (appleworks, Word). How would I know if my fonts are corrupted? this is the only such problem I’ve ever had.

Update: I just noticed that the format bug (if a bug it is) happens only when I italicize a word in a plain text Devon note, not a rich text note. So I’ll probably just make rich text notes from now on, which I’ve mostly been doing anyway so I can use highlighting, double spacing etc. I love that highlighting feature, BTW.

I just had this happen in a plain text note when trying to underline one word. It underlined the whole thing!! I’d say this qualified as a bug of some sort.

In fact it does this with any kind of formatting I attempt–bolding, italics, underline. I select one word, apply the formatting, and everything is formatted that way in the whole field. I hit undo and the formatting goes away but the entire text of the note is highlighted. This doesn’t seem at all normal!

Maybe it just doesn’t like us Oregonians.

“Maybe it just doesn’t like us Oregonians.”

Ha! Where are you in Oregon? And how could it not like US?? javascript:emoticon(’:D’)

That IS normal behavior for plain text, which doesn’t accept formatting.

Rich text is called rich because it accepts formatting such as bold, italic, underline, etc.

If you want to use bold, italic, etc. in a DT note that’s in plain text, first convert the note to rich text. Go to the menubar and select Format > Make Rich Text.

Conversly, to strip all character formatting from a rich text document, go the the menubar and select Format > Make Plain Text.

You’re right, of course. I was confusing text only with plain text, because in text only mode in Word, for example, I can do simple formatting. But of course, plain text is, well, plain. The only reason I started using plain text notes at all was speed–I was noticing some of the larger rtf notes taking too long to load.

Thanks for clearing that up!