Funny story: The sync just deleted most of my main database

Yep. Turned on the computer this morning, watched the sync go off, watched it delete 1,600+ files, and stared at my db for a good minute before it sunk in that it was almost empty.
Restored a backup from yesterday, but that’s just the metadata, the files themselves are still gone.

So right now I have no idea what to do.

Hi. I am sorry to hear about that. If you have a backup (Time Machine) there should be no problems. I index my files, which sit inside a cloud service, so that provides an additional layer of backup. If you were doing anything like this, then you can find them that way.

Regardless, you’ll want to contact customer support directly. They’ll want to know the details so that they can prevent this from happening again in the future, and hopefully they can also give you advice on how to proceed from here based on your particular situation. Hang in there.

Thanks, Frobgoblin. Time Machine saved the day indeed. My first try didn’t succeed, because my databases are in an encrypted folder, and Time Machine saves that folder as a package, it doesn’t go into the folders inside (which is where I looked initially). I then tried Backblaze, but they only had a backup from yesterday, which would have lost me my Evernote stuff (which I imported into DT yesterday and then deleted from Evernote, just bad timing).
Long story short: it looks like everything is back up now, but I don’t trust the sync anymore. I’ll contact support.
Thanks again.

I’m glad it worked out!

Indeed, sync (in any application – I’ve lost data in Evernote many times as well) is something that I have a difficult time trusting. There are so many complications, and so many things that can (and do) go wrong. I feel very uncomfortable working without multiple backups and methods for recovering data.

Although a lot of thought has been put into DTTG2, and lots of testing, it is a relatively new app, and I’d recommend folks take precautions (as you did), just in case something goes wrong.

It’s actually the first report of its kind ever but without additional details it’s hard to tell whether it’s a bug of the sync or not. Could you please choose Help > Bug Report (after pressing the Alt modifier key) and send the email to cgrunenberg - at - Additional details how to reproduce this would be useful too. Finally, what kind of devices do you synchronize and what kind of sync location do you use? Thanks!

I should mention that a month later, everything has been smooth sailing.