Global Inbox corruption

Hi, today I’ve been trying to use Dropbox sync with my Global inbox. It will sync for about a minute or two start uploading files but then I get an error stating that it appears to be damaged. It’s new, large database, and I have the same problem with my 2 backups. I’d greatly appreciate suggestions for fixing this problem.

I’m assuming that you are not placing your databases directly in the Dropbox folder (which we STRONGLY discourage), but are using the Sync procedure to share databases on more than one Mac, or the Sync procedure of DEVONthink To Go.

Run Tools > Verify & Repair to check for errors, and run it a second time if errors are reported, in an attempt to correct them.

If errors are found and cannot be corrected, Sync will not work (which is a Good Thing).

If errors persist, I would Quit DEVONthink. From the Finder, select your User Account in the left column. In the menubar choose Go, then Go to Folder. Type “~/Library” (without quotes) in the query field to make the User Library folder visible.

Now navigate from the Library folder to /Application Support/DEVONthink Pro 2/ and select the Global Inbox database, which is named “Inbox.dtBase2”. Control-click on that file and select the option that allows you to Move it to another location, such as Desktop or Documents.

Launch the DEVONthink application. A new, empty Global Inbox will be created.

Now double-click on the old Global Inbox database, Inbox.dtBase2, to open it.

Choose Tools > Rebuilt Database. When that procedure is complete, choose Window > Log, which will contain a list of items that failed to make the transfer (don’t worry about the “no text” listings). Save the list for future reference, if those files can be recaptured from another source.

You should now have a functional recovery of the old Global Inbox. Move the documents to another database. Note: You might use the Groups & Tags panel (Tools > Show Groups & Tags—there’s a keyboard shortcut) as a convenient way to drag selected items to another location.

With errors cleaned up, Sync should now work.

Hi Bill,
I appreciate your suggestions. But, even after doing all the steps that you suggested I am getting the following error:

2:46:23 PM: Sync: Inbox → (Dropbox) jterms.MYD: Couldn’t retrieve the content for the record; the record may be incomplete or damaged.

Do you have any more suggestions?

Thanks, Gilberto

Do you have a document in the Inbox named “jterms.MYD”? Is the “size” greater than zero? Does deleting the item and emptying the Trash fix the problem?

This is the second report of .myd files in your Inbox. These are (or appear to be) generate by MySQL. Are these indexed or imported??

Dear Korm,
Thank you for the suggestion. I tried deleting those files. No luck.

Thanks, G

Dear Bluefrog,
I’m sorry you’re getting too technical for me. I’m not sure how to reply.

Best, G

You don’t know if the files are indexed or imported? Look at the file in DEVONthink. If it has the little curved arrow icon pointing upward to the right then it is indexed – otherwise it is imported.

Dear Bluefrog,
After days of experimentation, I think I solved the problem. I deleted some problematic files and things seem to be syncing smoothly. Thanks for chiming in. :smiley: . I’ll update in a few days.