Global Inbox not syncing

So I’ve read/searched all the documentation on the forum and elsewhere and haven’t been able to figure this out. I’m running Devonthink 3 3.8.5 on my 14" M1 Pro MacBook Pro and DTG 3.5.5 on my iPhone 13 pro max and iPad.

The global inbox syncs between my DTG devices but not to Devonthink 3. I’ve emptied my inbox on all devices and tried syncing, I’ve verified, cleaned, etc… to no avail. I’m using iCloud sync (CloudKit). I even tried stopping iCloud sync and used Dropbox sync and that did not work either.

All the other databases I have sync between devices perfectly, just not the global inbox.

Just checking, as you did not mention it, in DEVONthink on MacBook, in the sync setup have you turned on synching for the Inbox (checkbox filled in)?


Anything reported in the Log ?

Have you tried Bonjour (although I doubt that makes a difference but try anyway.)

Nothing else comes to mind but i am sure this discussed previously here with resolution achieved.

I’ve had similar sync problems with the inboxes as well as many other databases and nothing would help… until I connected with Bonjour, got everything synced and switched back to CloudKit . Everything seems to work now. And the Bonjour sync really went fast.

1 Like

Cool. Glad it seemed to have an impact on the issue. Surprising to me, but there must be a reason!

Rather than switching back to CloudKit, which is known to be unreliable and slow for some (many?), why not keep BOTH CloudKit and Bonjour turned on. Maybe Bonjour can do all the work when possible and leave little to nothing for CloudKit to do?

1 Like

Welcome @Kgray01

Following what @rmschne mentioned…

  • What is reported in DEVONthink’s Window > Log?
  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, tap it. What is reported?

The log said that the database had inconsistencies and to repair it. I repaired it multiple times, verified, rebuilt, optimized, etc…

I ended up closing my databases, cleaned out the global inbox, uninstalling and reinstalling DT3 and now all is well, resyncing perfectly.

Thanks for everyone’s responses! I ended up reinstalling DT3 and all is well.

1 Like

You’re welcome. We hope you’re being diligent in your backups as well.