Global Inbox Showing "2" in Favorites, But There Are No Documents

My Global Inbox, under my favorites menu, is showing a “2” next to it, but there are no documents inside. Under the “Globals” menu, it’s showing no badge at all, which is accurate.

I’ve tried verifying, cleaning, and re-uploading the Global Inbox, but that didn’t work. I tried removing it from favorites and re-adding, and that didn’t work either.

Any other ideas on how to fix this? Thanks in advance for anyone’s help!

Does a toolbar search for item:unread scope:inboxes return any items? In addition, just curious but why did you add the global inbox to the favorites?

Thanks for the reply!

I tried that search, and since I have unread items in other database inboxes, I got results – so I’m not sure what’s going on.

You bring up a good point though, not sure why I need inboxes in the Favorites menu when I can just drag items to the menu bar icon to import them into whichever inbox I’d like…

Maybe I’ll just switch things around and avoid this issue altogether… Thanks!