Group disappears when I drag it to the smart rule


I was advised to drag certain groups to smart rules in order to initiate the the smart rule command’s that would apply to a group. But whenever I drag a group to the smart rule, the group disappears.

How can I fix this?


Disappears as in is lost from your database?

1 Like


Once I’ve had coffee, I’ll see if I can replicate that behaviour in my test database :flushed:

1 Like


So, on performing a basic test, I can’t replicate what you have described.

Can you post an example of a smart rule you are dragging to, please?

Presumably you are then dragging the group in question (group, not smart group?) on to the smart rule in the sidebar? Where are you dragging the group from (so from the sidebar or from the list view)?

Which actions does the rule perform?

1 Like


If the smart rule uses Move and File actions moving the dropped items to a different database/group, then it’s actually the expected result that they disappear from the current view.

Hmmm… It seemed like an error when I spoke to @BLUEFROG about this weeks ago.

Is there another way to initiate the smart rule commands (i.e., to move files from the existing group to it’s intended destination) without moving a group to a smart rule?


You don’t move the group to the smart rule (as smart rules/groups don’t contain data), you move the group to the destination specified by the actions of the smart rule. Therefore changing the actions would be required.

Maybe I’m not explaining the process properly or I might be misunderstanding you. To back up for a second, when @BLUEFROG generously helped me with all of this weeks ago he showed how I could drag a group to the smart rule – in effect, triggering the smart rule and having it affect the group – so that files in said group would move from there to their intended location (per the commands in the smart rules).

But when I tried to do this, the group just disappeared when I dragged it on the smart rule. So, maybe I did something wrong – or maybe there’s some error that needs to be corrected. In any case, I’m happy to do something else that would get the smart rule to apply to certain folders that already contain files.

I hope this is a helpful explanation. Thanks again for your help…

In this case the actions of the smart rule are applied to the group (that’s the dropped item), not to the files in the group.

Ok, thanks. As I said, it seemed to work perfectly when @BLUEFROG did it. In any case, what should I be doing differently?


You should drop the items inside the group onto the smart rule as the actions of the rules are applied to the dropped items.

1 Like

It worked!!!

My God, you’re a genius.


Now if only you can solve the rest of the problems that I’ve been struggling to fix!

Thanks so much again, @cgrunenberg … Truly.

You’re welcome.