Having Trouble Indexing Files Stored in Keep It

I have folders and files in Keep It that I want indexed in DT. I have used “Index Files and Folders” to do the initial indexing, and everything works fine the first time. Every folder and file I select gets indexed in DT. However, when I create a new file in Keep It in a folder that is already indexed in DT, the file does not initially get indexed anywhere in DT. But if after creating the new file in Keep It I then move it from one Keep It folder to another and then either (1) leave it there or (2) move it back to the folder where I first created it, it then shows up in DT as a properly indexed file. Clicking “Update Indexed Items” doesn’t solve the problem. Nor does closing and reopening DT or doing the same for Keep It.

l have no idea why this is happening and hope someone has a solution.

What’s the path of the created file and what’s the path of the enclosing group in DEVONthink where it should be added? In addition, is anything logged to Windows > Log?

Thanks for the reply. This is path for the file in Keep It that I want to have indexed in DT3:

/Users/jstaats/Library/Group Containers/D75L7R8266.com.reinvented.KeepIt/Keep It/Files/Research Projects/Women’s Rights Project/Notes/Test Note 1

I don’t really understand the path in DT3. DT3 is installed on my computer in the default location. Looked at schematically in DT3, here is where I want the file to be indexed in DT3:

Research [my DT3 database]
Research Projects
Women’s Rights Project
Test Note 1

When I add a new note in the notes folder in Keep It, it doesn’t get immediately indexed in the Notes group in DT3. But if I then move the new note file into another folder in Keep It, such as Papers and Writings, which is at the same level in Keep It as the Notes folder, and then move the new note file back into the Notes folder in Keep It, it then becomes properly indexed in the Notes group in DT3. If I instead leave the new note file in the Papers and Writings folder in Keep It, it then is indexed into the Papers and Writings group in DT3.

I don’t understand your question about something being logged to Windows > Log. I assume you are asking something about the Windows operating system. I don’t have Windows installed anywhere on my Mac.

I don’t think you can successfully index the contents of Keep It containers. You may have to choose the option to use iCloud Drive in Keep It, and then index those folders. Perhaps contact Reinvented Software to confirm.

I just tried a bunch of new note files created in Keep It to see if they would show up in the DT3 log. Nothing shows up in log, even when I successfully get DT3 to index a file by transferring it from one folder in Keep It to another. With this latest batch of new note files in Keep It, DT3 does not index the file when I first create it, but when I move the file in Keep It to another folder, the file shows up, for the first time, as an indexed file in the corresponding DT3 group. All of this is consistent with what I reported in my first post. But, as I said, none of these transactions show up in the DT3 log.

In answer to Greg_Jones, I don’t see any option in the Keep It preferences to switch from containers to iCloud Drive.

If no one in this forum is able to suggest a solution to my problem, I’ll contact Reinvented Software for a possible solution. But for now, I’ll await for any further suggestions/questions in this forum.

Thanks to everyone for the help.

When you launch Keep It, you would have seen this…

And there’s an option in its Keep It > Library menu…

However, this appears to indeed by using the Group Containers directory, not a folder in iCloud Drive.

I had a different response, but Bluefrog’s post made my info irrelevant. Given the info that Bluefrog shared, there’s probably no benefit to using iCloud if you are not using Keep It on iOS.

When I first installed Keep It some months ago, I opted to have iCloud make my data available on all my devices (iPhone and iPad), and I regularly view my data on my iPhone. But if I understand your message, it appears that selecting the iCloud option doesn’t mean Keep It doesn’t continue to use Group Containers, which may be the source of the problem. I don’t understand how Group Containers work or what the significance of this would be for the proper operation of DT3. In any event, are you suggesting that this problem can’t be solved at the DT3 end of things? In other words, I would need to contact Reinvented Software if I am ever to get this to work correctly in DT3?

Thanks for your help.

Just curious, but are the note files you are creating the default Keep It note format? I ask because I didn’t think those were viewable outside of Keep It anyway. If so, do you see the same behavior in DEVONthink if you create a plain text document in Keep It?

That’s a good question. I just checked to make sure. I have confirmed that I get the same behavior for my notes no matter what file type I choose, whether it be plain text, Word, or the default Keep It note file. So, a Keep It default note file will be indexed in DT3, but only after I move it from one folder in Keep It to another.

While I would agree with @Greg_Jones on the usefulness of using iCloud without having another machine or iOS device running their mobile app, I am not seeing an issue with indexing this location and having new files updating in it automatically.

Oddly, if you opt out of iCloud and remove the data, things are still store in the Group Containers directory. However, that would be a question for them.

It seems strange that you can get DT3 to index a file from Keep It the first time, but nothing happens when I do it. I have to first move the file to another folder in Keep It to ever get it indexed in DT3.

However, I have a bit of new information that may help. When I move a file to a folder in Keep It that is not already indexed in DT3 and then move the file back to the proper Keep It folder, the file DOES NOT then appear as an indexed file in DT3. Which means that I can only get DT3 to index a file if I first move it to another folder in Keep It that has a counterpart group in DT.

And by the way, I tried rebooting my computer, thinking that might help, as it does sometimes with other programs, but that didn’t change anything about the behavior I have described.

Are you creating the files in a group in Keep It?

I am not sure what you are asking about when you say “files in a group.”

I am creating my files one at a time within an existing Keep It folder that has already been indexed in DT3. Once I create an individual file, I look to see if it appears as an indexed file in the corresponding DT3 group. Each time I do this for an individual file, I don’t see the individual file in the appropriate DT3 group or anywhere else in DT3. But when I then transfer the individual file to some other existing Keep It folder that has already been indexed in DT3 and then immediately move it back to the original Keep It folder, then (and only, then) it shows up in in the appropriate group in DT3.

Here’s something to see if you can narrow down the problem a bit. Instead of creating the file, then switching immediately to DEVONthink to see if it is in the indexed folder, try this:

  1. Create the document in KI
  2. In KI, select the Show Files in Finder menu command pictured in the image posted above
  3. Verify that the document does appear in the appropriate Finder folder
  4. Then open DEVONthink and see if the document appears in the indexed group (you may or may not need to execute DEVONthink’s Update Indexed Items command).

I’m wondering if it’s possible that if you have been creating the document in KI and then immediately switching to DEVONthink, it may not appear if KI has cached the file and has not yet written it to disk. The above steps should confirm if that is or is not the case.

Thanks for the suggestion. I did try that some time ago and just did it again to make sure. I can see any given file I create both within the Keep It display and also when I look for it in Finder. The only place I can’t find it initially is in DT3. Executing the DT3 Update Indexed Items command has no effect.

One other thing I tried is to remove the indexed folders and files from DT3 and start a new process of indexing folders and files. That brings all existing Keep It folders and files into DT3. But when I create a new file, I still have the same situation of not seeing the file in DT3 until after I move it from one Keep It folder to another.

Here is something else I discovered that may help in understanding what is going on.

When I move a Keep It file that is indexed in DT3 from one DT3 indexed group to another indexed group, the file appears in the second DT3 group but has disappeared from the original DT3 group. That is what I expect to happen. But when I then look in Keep It to see what has happened there, I discover that the file is now in two Keep It folders, the original folder and the new folder that corresponds to the new DT3 group that I moved it to. So, I end up with two files in Keep It, but only one file in DT3. When I do the same thing with files indexed in DT3 from folders that do not reside in Keep It, I end up only with a file in the new folder, not both folders. That is how things should work. So something strange is happening in terms of Keep It communicating with DT3.

Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - devon-technologies.com - maybe there’s something useful in the logs. Thanks!