Help! I’ve lost my database

I dropped my computer in the bath the other day; it’s completely fried as a result. No matter, I thought: my DT3 databases are backed up in the cloud. Sure enough, I was able to re-import them to my new computer from their iCloud (Cloudkit) location. All except one: as it happened, the largest one, my library of research files.
It downloaded about half-way, then stopped, sending hundreds of notifications to the log that <<File “longstringofgibberish.manifest” is missing of database “Library.”>>
I tried importing several times, then, in despair, tried the “Clean Database” command, thinking it might fix the problem. Instead it vaporized the whole database.
So now it would appear to exist neither on my computer nor the cloud. Is it really gone for good? Is there some way to retrieve it? Can anyone help?

Sorry for your loss. While bathtubs have not been in my experience in crashing laptops, I’ve had a few disasters over the years.

Sounds like you might have had some indexed files which are by their nature only indexed in DEVONthink, but not stored inside the database. At this point, especially since you “cleaned” the sync location in CloudKit (which is the same as deleting it–sorry), there is probably no chance getting the sync’ed version, nor the indexed files, back.

Your best option at this point is to revert to your “backup” of your computer that you may have made with your Mac’s TimeMachine backup software. You don’t mention it so I have strong hunch you have no back up. Ooops.

Maybe someone else has another idea.

I’m not trying to rub it in or take advantage of your situation to re-make a point, but this is a clear example of why the sync locations (on a cloud-based server or elsewhere) should never be considered a “backup”. Their purpose is to facilitate the movement of DEVONthink databases from one machine to another. They are NOT a backup. Just not. All covered in the DEVONthink Manual and here many times.

Have you tried to undelete the data on iCloud?

I’ve never tried it and its @acoyne with the issue who might try it. Looks hopeful, but missing indexed files might be an remaining issue.

That not only stinks, it sounds potentially dangerous!

And also not rubbing salt in a wound, but @rmschne is correct about sync not being a backup. Can it provide some restoration capabilities in an emergency? Possibly. However, if the sync data isn’t intact, then it can’t. And no that’s not the purpose of syncing.

We strongly advocate proper primary backups using TimeMachine (or similar snapshot-style backup applications) and external drives. Arq (used by our company president) is a good option for online backups. Also, you should read the series of articles we posted: DEVONtechnologies | Search & Find